maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Kielty <shawn.kie...@macys.com>
Subject RE: Maven-release-plugin AND IBM RTC build engine...
Date Fri, 03 May 2013 17:29:38 GMT
What if ... the directory is not actually shared ... In the windows sense. 
 On the command line of the build server type "net share" and see if the 
directory is on the share list. 



From:   "Zanzerkia, Robert" <Robert.Zanzerkia@fmr.com>
To:     Maven Users List <users@maven.apache.org>, 
Date:   05/03/2013 09:35 AM
Subject:        RE: Maven-release-plugin AND IBM RTC build engine...



I did few more experiments...
1) Renamed the RTC component so there is no space in the name.
2) Made sure directory has permission for build account etc.
3) Experimented by replacing maven command to just mvn scm:status and that 
works without error.
                 So it's only via release-plug-in we get the error on scm 
status command.

                 Since replease-plug-in works on my laptop this is an 
issue on interaction between maven, release-plugin and "Jazz build engine"
                 I re-ran the RTC build with -X switch in maven to get 
detailed log so we can compare against release.log (one from my laptop).
  Thanks,
Robert
PS: I have attached  RTC_JAZZ-Build.log from build server. 

Working release.log
[DEBUG] repositoryWorkspace - EI_9.05_Release_Snapshot
[DEBUG] Executing status command...
[INFO] Executing: cmd.exe /X /C "scm status --username a408072 --password 
***** --wide"
[INFO] Working directory: C:\Documents and 
Settings\a408072.DMN1\workspace301-EI-9.05_Rel\EI AS-ITAM uCMDB Pattern 
DEV
[DEBUG] Consumed line :Workspace: (1189) "EI_9.05_Release_Snapshot" <-> 
(1001) "EI AS-ITAM uCMDB 9.02 EI Stream"


NOT working RTC build lines.
[DEBUG] repositoryWorkspace - 
srvrtcbuild-EI-AS-ITAM-PatternDEV-DEV_Release_WS
[DEBUG] Executing status command...
[INFO] Executing: cmd.exe /X /C "scm status --username srvrtcbuild 
--password ***** --wide"
[INFO] Working directory: D:\RTCBuildWorkspace\EI-ITAMTEST\uCMDBPackages
[DEBUG] ErrorConsumer.consumeLine: Problem running 'status':
[DEBUG] ErrorConsumer.consumeLine: Current directory is not shared. Run 
from a shared directory.
[ERROR] Error: Problem running 'status':
Current directory is not shared. Run from a shared directory.
 

-----Original Message-----
From: Zanzerkia, Robert 
Sent: Tuesday, April 30, 2013 11:56 AM
To: Maven Users List
Subject: RE: Maven-release-plugin AND IBM RTC build engine...

Hi,
 Actually it was Chris who helped me... Thanks Chris.

 When I said NO access to RTC Build engine I meant for the physical server 
where the build runs.
 We have a support group that manages these servers which is why I don't 
have the direct access.
 (Yes that makes it more difficult to trouble shoot).

 I am working with the local person to trouble shoot the issue.

 The issue comes down to the scm -status command where on my laptop it 
works fine but on the RTC build engine it gives below error.

We have defined 
-DworkingDirectory = D:\temp\Maven (for the plugin working directory).
repository local directory = 
<localRepository>D:\data\mavenrepo\ei_itam_discovery</localRepository>
RTC load directory: load directory = ${BUILDWORKSPACE}\EI-Discovery2 

 
[INFO] --- maven-release-plugin:2.4.1:prepare (default-cli) @ 
uCMDB-PatternDev ---
[INFO] Verifying that there are no local modifications...
[INFO]   ignoring changes on: **\pom.xml.tag, **\pom.xml.branch, 
**\pom.xml.releaseBackup, **\pom.xml.backup, **\release.properties, 
**\pom.xml.next
[INFO] Executing: cmd.exe /X /C "scm status --username srvrtcbuild 
--password ***** --wide"
[INFO] Working directory: D:\RTCBuildWorkspace\EI-Discovery2\EI AS-ITAM 
uCMDB Pattern DEV
[ERROR] Error: Problem running 'status':
Current directory is not shared. Run from a shared directory.

Thanks,
Robert

-----Original Message-----
From: Stephen Connolly [mailto:stephen.alan.connolly@gmail.com] 
Sent: Monday, April 29, 2013 11:25 AM
To: Maven Users List
Subject: Re: Maven-release-plugin AND IBM RTC build engine...

Perhaps Chris Graham might be able to help... given that from what I
understand IBM decided not to let him go!!! Of course that assumes he has
access to the toolchain!


On 29 April 2013 16:07, Wayne Fay <waynefay@gmail.com> wrote:

> >   I still DO NOT have the release plug-in working with RTC build 
engine.
> ...
> > work as well, unfortunately I don't have access to RTC build engine...
>
> And this is exactly the reason why the release plugin does not work
> with RTC build engine.
>
> If you don't have access to RTC build engine, yet you are a customer
> of IBM's and use their tools etc, how can any random open source
> developer be granted the necessary access to these tools (Jazz, RTC,
> etc) so the release plugin can be adapted as needed to work along with
> it?
>
> This is why Maven plugins for proprietary tools will ALWAYS lag in
> functionality behind open source tools. For all intents, it
> practically requires the VENDOR to put in the effort to build/adapt
> the plugin for their products. If you have the ability to do so, I'd
> open a bug/ticket with IBM and ask them to support the Maven release
> plugin, otherwise I doubt this functionality will ever be added by
> anyone else.
>
> Wayne
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message