maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curtis Rueden <ctrue...@wisc.edu>
Subject Re: [ERROR] OverConstrainedVersionException
Date Fri, 24 May 2013 17:42:48 GMT
Hi proverbio,

> Couldn't f ind a version in [1.0.0-v20070423, 1.0.0-v20070606] to
> match range [1.0.0,2.0.0)

Maven treats qualified versions (e.g., 1.0.0-rc1) as coming *before* the
unqualified "final" release (e.g., 1.0.0).

In your case, both 1.0.0-v200704023 and 1.0.0-v20070606 (and anything in
between) come before 1.0.0, which is the earliest allowed revision in the
range [1.0.0,2.0.0).

Some relevant articles:
http://docs.codehaus.org/display/MAVEN/Dependency+Mediation+and+Conflict+Resolution
http://aspsp.blogspot.com/2008/02/maven-dependency-version-ranges-are.html
http://stackoverflow.com/questions/7167250/should-maven-dependency-version-ranges-be-considered-deprecated

Regards,
Curtis


On Fri, May 24, 2013 at 9:55 AM, proverbio <proverbio8@gmail.com> wrote:

> Hi all!
>
> I am getting this error when I am trying to build a project. This artifact
> is a transitive dependence. I have the artifacts "app-1.0.0-v20070423.jar",
> "app-1.0.0-v20070606.jar", and the
> org.eclipse.core:runtime:jar:3.3.100-v20070530 in my local repository, so I
> don't understand why my maven don't finish correctly the build.
>
> Thanks in advance for the help!
>
>
> org.apache.maven.artifact.versioning.OverConstrainedVersionException:
> Couldn't f
> ind a version in [1.0.0-v20070423, 1.0.0-v20070606] to match range
> [1.0.0,2.0.0)
>
>   org.eclipse.equinox:app:jar:null
>
>
> [ERROR] An error occurred during dependency resolution of the following
> artifact
> :
>     org.eclipse.equinox:app:null
> Caused by: Couldn't find a version in [1.0.0-v20070423, 1.0.0-v20070606] to
> matc
> h range [1.0.0,2.0.0)
>   org.eclipse.equinox:app:jar:null
>
> Path to dependency:
>         1) uy:geopos2:jar:1.10.b25-SNAPSHOT
>         2) uy:geopos2-context:jar:1.3.b7
>         3) camel:apache-camel:jar:1.6.1
>         4) org.apache.camel:camel-bundle:jar:1.6.1
>         5) org.eclipse.core:runtime:jar:3.3.100-v20070530
>
> Thanks! :)
>
>
>
>
> --
> View this message in context:
> http://maven.40175.n5.nabble.com/ERROR-OverConstrainedVersionException-tp5756918.html
> Sent from the Maven - Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message