maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curtis Rueden <ctrue...@wisc.edu>
Subject Re: NullPointerException in SSH wagon
Date Wed, 24 Apr 2013 17:19:28 GMT
Hi Mark,

> The problem is that wagon-ssh seems more or less undocumented, and so
> there's no indication that it supports keys loaded into OpenSSH's
> ssh-agent. We exclusively use public keys for security reasons.

A quick Google search [1] suggested that you can use the <privateKey>
element of settings.xml [2]. I didn't try it, but it sounds promising.
Would that solve it for you?

Regards,
Curtis

[1] http://lmgtfy.com/?q=wagon-ssh+maven+public+ssh+key
[2] http://stackoverflow.com/a/2733722


On Wed, Apr 24, 2013 at 12:13 PM, <org.apache.maven.user@io7m.com> wrote:

> On Wed, 24 Apr 2013 11:54:08 -0500
> Curtis Rueden <ctrueden@wisc.edu> wrote:
>
> > Hi Mark,
> >
> > > <artifactId>wagon-ssh-external</artifactId>
> >
> > Rather than SSH External, did you try using the Maven SSH wagon [1]
> > instead? It uses JSch, which is pretty good now.
> >
> > My impression is that the "Deployment of artifacts in an external SSH
> > command" guide [2] is rather obsolete now.
> >
>
> 'Lo.
>
> The problem is that wagon-ssh seems more or less undocumented, and so
> there's no indication that it supports keys loaded into OpenSSH's
> ssh-agent. We exclusively use public keys for security reasons.
>
> Is there a way to get that to work?
>
> M
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message