maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Baptiste MATHUS ...@batmat.net>
Subject Re: error in unit test
Date Thu, 07 Mar 2013 20:32:39 GMT
Hi,
This is more a question for jenkins users ml.
I suppose you're using a Maven native type of job. Does it produce the same
error with a freestyle job&Maven step?

And also check you're using the same Maven version locally and in jenkins.
But from your logs, I don't think it's related.

Cheers
Le 7 mars 2013 21:25, <Alejandro.Endo@miranda.com> a écrit :

>
>
> I have a problem where my maven plugin's unit tests fail ONLY when i run
> them in jenkins. When i run `mvn test` locally everything passes fine
>
> The error i get is
>
> Tests in error:
>   testGetMyModules(com.example.AnalyzerTest): (class:
> org/apache/maven/project/MavenProject, method:
> getSnapshotArtifactRepository signature:
> ()Lorg/apache/maven/artifact/repository/ArtifactRepository;) Incompatible
> argument to function
>
> Does anyone know what this is related to?
>
> Thank you,
>
>
> Alejandro
> DISCLAIMER:
>
> Privileged and/or Confidential information may be contained in this
> message. If you are not the addressee of this message, you may not
> copy, use or deliver this message to anyone. In such event, you
> should destroy the message and kindly notify the sender by reply
> e-mail. It is understood that opinions or conclusions that do not
> relate to the official business of the company are neither given
> nor endorsed by the company.
>
> Thank You.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message