maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <and...@hammar.net>
Subject Re: Initialize not running during Install?
Date Tue, 05 Mar 2013 13:10:02 GMT
It turns out I was wrong. You got the answer to why this happens from
someone else in this thread.

/Anders


On Tue, Mar 5, 2013 at 2:06 PM, Macbeth, Andrew (US SSA) <
andrew.macbeth@baesystems.com> wrote:

> Anders,
> I included the debug output and pom.xml's in my previous message.
> Wondering if they didn't make it through to you. I've reattached them to
> this message. If attachments aren't making it through, I'll resend with
> contents pasted into the body of this message.
>
> A quick visual comparison of the debug output of initialize vs. install
> indicates that the following does appear in initialize and does not appear
> in install:
>
> [INFO] Installing ***/***/***/***/lib/jnetpcap.jar to
> ***/***/.m2/repository/jnetpcap/jnetpcap/1.3.0/jnetpcap-1.3.0.jar
>
> Andy
>
> -----Original Message-----
> From: anders.g.hammar@gmail.com [mailto:anders.g.hammar@gmail.com] On
> Behalf Of Anders Hammar
> Sent: Friday, March 01, 2013 2:18 AM
> To: Maven Users List
> Subject: Re: Initialize not running during Install?
>
> I doubt that this plugin is not executed when you perform a "mvn install"
> if it executes for "mvn initialize". If it would be the case, it's a bug
> in Maven core.
>
> If you're using Maven 3, the console output will very clearly state the
> plugins being executed. Could you execute "mvn install" and ensure the
> plugin is not being executed. Compare to the output of "mvn initialize".
>
> If you still think something is wrong, we need a test case to try to
> reproduce.
>
> /Anders
>
>
> On Thu, Feb 28, 2013 at 3:47 PM, Macbeth, Andrew (US SSA) <
> andrew.macbeth@baesystems.com> wrote:
>
> >  I am attempting to configure maven-install-plugin:install-file in my
> > pom.xml. I want to install a third-party jar into my local repo. I
> > prefer to run this in the pom.xml instead of command line so that
> > developers on the team are unaffected and do not have to manually
> > perform the install. An extract from my pom.xml is below.
> > <install-file> is set to run during the initialize phase. When I
> > execute "mvn initialize" the jar is successfully installed into my
> > local repo. However, when I run "mvn install", it does not get installed
> (yes, I am clearing out the local repo between runs).
> > Very puzzling. I have attached the parent and module poms, and the
> > debug outputs from mvn initialize and mvn install.****
> >
> > Help.****
> >
> > ** **
> >
> > <project>****
> >
> >                <build>****
> >
> >                               <plugins>****
> >
> >                                              <plugin>****
> >
> >
> > <groupId>org.apache.maven.plugins</groupId>****
> >
> >
> > <artifactId>maven-install-plugin</artifactId>****
> >
> >
> > <version>2.4</version>****
> >
> >
> > <executions>**
> > **
> >
> >
> > <execution>****
> >
> >
> > <id>install-jnetpcap</id>****
> >
> >
> > <phase>initialize</phase>****
> >
> >
> > <goals>****
> >
> >
> > <goal>install-file</goal>****
> >
> >
> > </goals>****
> >
> >
> > <configuration>****
> >
> >
> > <groupId>jnetpcap</groupId>****
> >
> >
> > <artifactId>jnetpcap</artifactId>****
> >
> >
> > <version>1.3.0</version>****
> >
> >
> > <packaging>jar</packaging>****
> >
> >
> >                <file>${project.basedir}/lib/jnetpcap.jar</file>****
> >
> >
> > <generatePom>true</generatePom>****
> >
> >
> > </configuration>****
> >
> >
> > </execution>****
> >
> >
> > </executions>*
> > ***
> >
> >                                              </plugin>****
> >
> >                               </plugins>****
> >
> >                </build>****
> >
> > </project>****
> >
> > ** **
> >
> > ** **
> >
> > Andrew J. Macbeth****
> >
> > BAE Systems, Inc., ES-AIT****
> >
> > 6 New England Executive Park, Burlington, MA****
> >
> > (781) 262-4742****
> >
> > ** **
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > For additional commands, e-mail: users-help@maven.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message