maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stadelmann Josef" <josef.stadelm...@axa-winterthur.ch>
Subject tomcat6:list - minimum requirements to run
Date Thu, 07 Mar 2013 11:26:16 GMT
Hi all,

I have some difficulty to understand how to use the plugin below to do a
simple $ mvn tomcat6:list

        <pluginManagement>
            <plugins>
                <plugin>
                    <groupId>org.apache.tomcat.maven</groupId>
                    <artifactId>tomcat6-maven-plugin</artifactId>
                    <version>2.1</version>
                </plugin>
                <plugin>
                    <groupId>org.apache.tomcat.maven</groupId>
                    <artifactId>tomcat7-maven-plugin</artifactId>
                    <version>2.1</version>
                </plugin>
            </plugins>
        </pluginManagement>    


I have integrated this plugin into my main pom.xml of the multi modul
project svnkit, of which svnkit-dav has a war file on board/generated.
Not an executable war file (what is that?) but just a war to be deployed
to a running tomcat AS.

As a starter, and not involfing any war file, I like just to know under
which circumstances I can use
$ mvn tomcat6:list

Josef - I have read the documentation and I am not clear what to do to
get an embedded tomcat OR how to use it.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message