maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <>
Subject Re: Apache Maven-2.2.1 failed to download repository
Date Thu, 03 Jan 2013 07:36:46 GMT
I'm fairly sure you had some configuration, like proxy, with your older
Maven installation that you're now missing.

First, I strongly suggest you always configure Maven through settings.xml
in your profile and not the one in the Maven installation. By doing that
you will have the same configuration for all Maven installations. Also, you
normally shouldn't have to clear you local repo all the time. But if you
do, you should delete .m2/repository only and not the entire .m2 folder in
your profile (as it would wipe out your settings.xml).

There's more info on configuring Maven here [1].



On Thu, Jan 3, 2013 at 7:53 AM, NeelamSharma <> wrote:

> Thanks Anders for reply.
> My system is in a network where all system are connected with a LAN, but I
> have tried downloading repository on a personal network (disconnecting my
> LAN and connected to a private net), then also facing same issue. One point
> is that earlier I was successful to download with same network. This time I
> am facing issue. Please let me know where to change configuration?
> In setting.xml (myfolder\apache-maven-2.2.1\conf\settings.xml) file these
> tags are commented
> <proxies>
> ...
> </proxies>
> This show that I am not downloading using Proxies.
> If there is issue of older maven version then also I tried downloading and
> setup latest version of Maven-3.0.4 (also tried Maven-3.0.3), but they also
> stuck exactly at same step as I am facing from start. It always downloading
> ".m2" of size 3.92 MB (4118659 bytes).
> I am always clearing my local repository from my user then restarting
> again.
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message