maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stadelmann Josef" <josef.stadelm...@axa-winterthur.ch>
Subject AW: maven jax-ws and jdk7. help please
Date Mon, 28 Jan 2013 17:53:46 GMT
I fully support that! 
I had a nightmare with Axis2-1.6.2 and JDK1.6.0_30
when it comes to use jax-ws and jaxb with "ALLOWED ANNOTATIONS";

Axis-1.6.2 has a jax-ws interface which knows about 4 args to some annotations,
so the compiler had absolute no problem. But then JDK 1.6.0_30 RT.jar has only 
an implementation for 3 args to be set on a annotation class, hence 
calling through the interface the 4 arg to be set, returnd a class not found 
exception.

The cure was to endorse from JDK 1.7 into JDK1.6.0_30/jre/lib/endorsed 
the proper jar files; This works now for us very well for Vista and OpenVMS

Josef 



-----Ursprüngliche Nachricht-----
Von: Jörg Schaible [mailto:Joerg.Schaible@scalaris.com] 
Gesendet: Montag, 28. Januar 2013 10:37
An: users@maven.apache.org
Betreff: Re: maven jax-ws and jdk7. help please

laudio.info wrote:

> Thanks
> 
> I have seen that, using the same java code and the same configuration, 
> the problem appears if i use the jdk7. Using the jdk there is not 
> problem

The jaxws plugin does not respect the compiler settings for source/target. 
On top of it, the exception has additional info since JDK 7, so any code that uses reflection
to map an exception class to something else, will be affected by the different Java runtime.
AFAICS JAXB is such a tool.

Nothing of this has to do with Maven directly though.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org

Mime
View raw message