maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte" <rfscho...@apache.org>
Subject Re: release plugin can not build site
Date Sun, 09 Dec 2012 10:00:50 GMT
Hi,

The install always happens before the deploy, I can't see why that's not  
happening.
Also, since it is part of the reactor-build, it should be able to pick it  
even without the 'install'.
I do see 1 interesting thing: all reports are configured in the  
maven-site-plugin.
Could you try to move the reports from the site-configuration to the  
reporting-section of the pom?
It that works, you've hit a bug: reactor-projects are not resolved when  
using reports inside plugin-configuration.

Robert


Op Sun, 09 Dec 2012 04:50:20 +0100 schreef Vitaliy Semochkin  
<vitaliy.se@gmail.com>:

> Hello Robert,
>
> Thank you for the fast reply
>
> I'm using 3.0.4
> I see that  repository4hibernate-shared is deployed but I don't see it
> is installed.
> Is there any way to force release plugin to install it?
>
> On Sat, Dec 8, 2012 at 2:16 PM, Robert Scholte <rfscholte@apache.org>  
> wrote:
>> Hi,
>>
>> which version of Maven are you using?
>> Do you see that the repository4hibernate-shared is installed/deployed  
>> before
>> getting this message?
>>
>> Robert
>>
>> Op Fri, 07 Dec 2012 23:32:28 +0100 schreef Vitaliy Semochkin
>> <vitaliy.se@gmail.com>:
>>
>>> Hi,
>>>
>>> I have a multi-module project that has following structure
>>>
>>> repository4hibernate
>>>   + repository4hibernate-shared
>>>   + repository4hibernate-api
>>>
>>> when I try to perform release
>>>
>>> When I run:
>>> mvn release:clean release:prepare release:perform
>>>
>>> I receive following error:
>>> [ERROR] Failed to execute goal
>>> org.apache.maven.plugins:maven-site-plugin:3.0:site (default-site) on
>>> project repository4hibernate-parent: failed to get report for
>>> org.apache.maven.plugins:maven-javadoc-plugin: Failed to execute goal
>>> on project repository4hibernate: Could not resolve dependencies for
>>> project net.sf.r4h:repository4hibernate:jar:4.1.21: Could not find
>>> artifact net.sf.r4h:repository4hibernate-shared:jar:4.1.21 in central
>>> (http://repo.maven.apache.org/maven2) -> [Help 1]
>>>
>>>
>>> However when I run
>>> mvn release:clean release:prepare release:perform -Dgoals=deploy
>>>
>>> everything goes fine.
>>>
>>> The question is, why the site plugin fails to find the artifact and
>>> how to make release plugin to deploy the site during the release
>>> process?
>>>
>>> here is the project source repository
>>>
>>> http://sourceforge.net/p/r4h/code/ci/dab65bf55bc93d14f6deffac254b71371203713f/tree/
>>>
>>> here is the parent pom
>>>
>>> https://sourceforge.net/p/r4h/code/ci/dab65bf55bc93d14f6deffac254b71371203713f/tree/pom.xml
>>>
>>>
>>> Thanks in advance.
>>>
>>> Regards,
>>> Vitaliy S
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>>> For additional commands, e-mail: users-help@maven.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: users-help@maven.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message