maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: No compile errors with plexus-compiler-eclipse
Date Sun, 02 Dec 2012 14:37:06 GMT

Hello Peter

I downloaded maven-eclipse-compiler version 1.9.2 from maven repo1 and was able to use the
pom.xml to compile and package 
here is the pom.xml i implemented:
<?xml version="1.0" encoding="UTF-8"?>
<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://maven.apache.org/POM/4.0.0">

<modelVersion>4.0.0</modelVersion> <parent> 
 <groupId>org.codehaus.plexus</groupId> 
 <artifactId>plexus-compilers</artifactId> 
 <version>1.9.2</version> 
</parent> <groupId>org.codehaus.plexus</groupId> 
<artifactId>plexus-compiler-eclipse</artifactId> 
<version>1.9.2</version>
<name>Plexus Eclipse Compiler</name> 
<dependencies> 
 <dependency>
    <groupId>org.codehaus.plexus</groupId>
    <artifactId>plexus-container-default</artifactId>
      <version>1.5.5</version>
   </dependency>
 <dependency>
  <groupId>org.codehaus.plexus</groupId>
  <artifactId>plexus-compiler-api</artifactId>
  <version>1.9.2</version>
 </dependency>
 <dependency> 
  <groupId>org.codehaus.plexus</groupId> 
  <artifactId>plexus-utils</artifactId> 
  <version>3.0</version>
 </dependency> 
 <dependency> 
  <groupId>org.eclipse.jdt</groupId> 
  <artifactId>core</artifactId> 
  <version>3.3.0-v_771</version> 
  <exclusions> 
   <exclusion> 
    <groupId>org.eclipse.core</groupId> 
    <artifactId>resources</artifactId> 
   </exclusion> 
   <exclusion> 
    <groupId>org.eclipse.core</groupId> 
    <artifactId>runtime</artifactId> 
   </exclusion> 
   <exclusion> 
    <groupId>org.eclipse.core</groupId> 
    <artifactId>filesystem</artifactId> 
   </exclusion> 
   <exclusion> 
    <groupId>org.eclipse</groupId> 
    <artifactId>text</artifactId> 
   </exclusion> 
  </exclusions> 
 </dependency> 
</dependencies> 
</project> http://repo1.maven.org/maven2/org/codehaus/plexus/plexus-compiler-eclipse/1.9.2
does this not compile for your environment?

Martin Gainty 
______________________________________________ 
Verzicht und Vertraulichkeitanmerkung/Note de déni et de confidentialité

Diese Nachricht ist vertraulich. Sollten Sie nicht der vorgesehene Empfaenger sein, so bitten
wir hoeflich um eine Mitteilung. Jede unbefugte Weiterleitung oder Fertigung einer Kopie ist
unzulaessig. Diese Nachricht dient lediglich dem Austausch von Informationen und entfaltet
keine rechtliche Bindungswirkung. Aufgrund der leichten Manipulierbarkeit von E-Mails koennen
wir keine Haftung fuer den Inhalt uebernehmen.
Ce message est confidentiel et peut être privilégié. Si vous n'êtes pas le destinataire
prévu, nous te demandons avec bonté que pour satisfaire informez l'expéditeur. N'importe
quelle diffusion non autorisée ou la copie de ceci est interdite. Ce message sert à l'information
seulement et n'aura pas n'importe quel effet légalement obligatoire. Étant donné que les
email peuvent facilement être sujets à la manipulation, nous ne pouvons accepter aucune
responsabilité pour le contenu fourni.

 > From: lists@zentrumderarbeit.org
> Subject: No compile errors with plexus-compiler-eclipse
> Date: Fri, 30 Nov 2012 08:47:08 +0100
> To: users@maven.apache.org
> 
> Hello,
> 
> I'm trying to make use of plexus-compiler-eclipse by setting
> 
> <plugin>
> 	<artifactId>maven-compiler-plugin</artifactId>
> 	<version>3.0</version>
> 	<configuration>
> 		<compilerId>eclipse</compilerId>
> 	</configuration>
> 	<dependencies>
> 		<dependency>
> 			<groupId>org.codehaus.plexus</groupId>
> 			<artifactId>plexus-compiler-eclipse</artifactId>
> 			<version>2.0</version>
> 		</dependency>
> 	</dependencies>
> </plugin>
> 
> in pom.xml.
> 
> mvn compile
> 
> works, but in fact I still have errors in my code (I'm actually porting an ant and xdoclet
based project to maven).
> But instead of getting errors I see a lot of warnings and build succeeds.
> 
> The warnings are not only about 
> 
> "Hashtable is a raw type. References to generic type Hashtable<K,V> should be parameterized"
> 
> which I'd expect as a warning only, but also
> 
> "Type mismatch: cannot convert from Object to MyBusinessFacadeRemote"
> or
> "MyBusinessServlet cannot be resolved"
> or
> "Unreachable catch block for RemoteException. This exception is never thrown from the
try statement body"
> or
> "The import foo.bar.Bla cannot be resolved"
> 
> or even whole types (formerly xdoclet generated types I partially need to create manually
by myself and haven't done yet).
> These I'd expect to pop up as an error and fail the build. Instead it's only printed
as a warning and build continues.
> 
> Am I configuring maven-compiler-plugin - and plexus-compile-eclipse - the wrong way?
> Or is plexus-compiler-eclipse not raising these errors as such at all, which would render
it quite a bit useless at the moment?
> -- 
> Thanks in advance,
> and best regards,
> 
> Peter
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message