maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Rollo <danro...@gmail.com>
Subject re: Proper fix for "non-resolvable" dependency in build server
Date Thu, 20 Dec 2012 02:14:05 GMT
Hi David,

By any chance, does the maven goals you are executing include the 'site' 
goal?

I ask because I saw a similar problem where the build works fine as long 
as you do not try to build the site - mvn clean deploy worked, mvn clean 
deploy site-deploy failed.

I had the same case of a parent pom that was plubished in our lan repo
manager server. The parent pom was found, and downloaded to the CI 
servers local m2 repo fine, but some how the 'site' goal was not finding 
it (yet other build phases were fine).

To make matters more confusing, I found that if I manually ran "mvn
install" on the parent pom project on the CI server, then suddenly the
'site' goal was fine.

Please let me know if your problem is similar (and my apologies if it is 
not).

Thanks,
Dan

PS: I previously reported this in this post:
http://www.mail-archive.com/users@maven.apache.org/msg127878.html
but haven't seen any replies.


On 12/19/2012 10:24 AM, users-digest-help@maven.apache.org wrote:
 > Subject:
 > Proper fix for "non-resolvable" dependency in build server
 > From:
 > "KARR, DAVID" <dk068x@att.com>
 > Date:
 > 12/18/2012 10:26 PM
 >
 > To:
 > Maven Users List <users@maven.apache.org>
 >
 >
 > I have a project that is building fine on my laptop.  Today I started 
to set up the build for this on our Bamboo server.  Everything is 
checked in.  Both my laptop and the build server are using Maven 3.0.4.
 >
 > I have a top-level aggregator pom that specifies several modules, but 
this pom is not the parent of any module.  I do use parent poms, but 
those parents are in peer directories, and I have blank "relativePath" 
elements in all poms.
 >
 > In the Bamboo build of the top-level aggregator POM, I see several 
errors like this:
 >
 > [ERROR]   The project com.example.cde:java-project-parent:1.0.1 
(/volatile/bamboo/bamboo3.4.3_data/xml-data/build-dir/FOO-BUILD-JOB1/java-project-parent/pom.xml)

has 1 error
 > 18-Dec-2012 16:40:21 	[ERROR]     Non-resolvable parent POM: Failure 
to find com.example.cde:project-parent:pom:1.0.0 
inhttp://hostname.net:8081/nexus/content/groups/stuff  was cached in the 
local repository, resolution will not be reattempted until the update 
interval of nexus has elapsed or updates are forced and 
'parent.relativePath' points at no local POM @ line 6, column 11 -> [Help 2]
 >
 > The "java-project-parent" is one of the poms in the parent hierarchy.
 >
 > I get that for some reason the "java-project-parent" artifact isn't 
in the local repository, but what exactly do I have to do to resolve 
this?  Do I have to run "mvn -U install" instead of "mvn install"?
 >


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message