maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tong123123 <tong123...@yahoo.com.hk>
Subject strange with repository element in pom
Date Tue, 11 Dec 2012 10:13:15 GMT
at first, my pom has not the following repository
<repositories>
        <repository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </repository>

and the project has error that it cannot download hamcrest from http://repo.maven.apache.org/maven2,
then I add the above JBoss repository to pom, delete the correponding folder in local repository
and select the project > maven > update project, the 

hamcrest jar can download successfully.
Then I delete the latest downloaded hamcrest jar file in local repository and remove the JBoss
repository element in the pom.
I expect the previous error will error, but out of my expectation, the hamcrest jar file can
be downloaded even I already remove the JBoss repository element from the pom 

and delete the hamcrest jar file from local repository, why the hamcrest jar file can still
be downloaded?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message