maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Javix <serguei.camb...@atos.net>
Subject Re: Getting profile settings values in a Java class
Date Thu, 06 Dec 2012 08:25:35 GMT
I knew those option to desactivate a profile. The problem that I can't figure
out how to solve is WHY the same Maven configuration works in one project
and not at all in another? By the way, if comment out the line 

<activation>
  <activeByDefault>true</activeByDefault>
</activation>

and run

mvn test -P [profile_to_use]

it works fine too. But in another project, no matter the way I use to run
Maven tests (commenting out the profile activation lines, running with
negation option (![profile_not_to_use], [profile_to_use], it does not work
and fails. So I have to set it up explicitly every time in the POM file.
Here is my configuration:

Apache Maven 3.0.4 (r1232337; 2012-01-17 09:44:56+0100)
Maven home: C:\Apache\apache-maven-3.0.4
Java version: 1.6.0_21, vendor: Sun Microsystems Inc.
Java home: C:\Program Files\Java\jdk1.6.0_21\jre
Default locale: fr_FR, platform encoding: Cp1252
OS name: "windows xp", version: "5.1", arch: "x86", family: "windows"

Regards



--
View this message in context: http://maven.40175.n5.nabble.com/Getting-profile-settings-values-in-a-Java-class-tp5722740p5735884.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message