maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <>
Subject Re: Re: Why does mvn compiile using java 1.3?
Date Fri, 30 Nov 2012 16:02:05 GMT
BTW I favour keeping at 1.5. That is the highest version we can guarantee a
user of Maven 3.1.0's JDK can compile at (because in order to run Maven
2.2.1+ you need Java 1.5) so unless they are using toolchains (which to be
honest, given the lack of bugs reported around toolchains and my knowledge
of what kind of bugs we should expect to see reported [xyz plugin doesn't
support toolchains] they are not using) that is a good and sensible default.

If we set the default higher, then a user will download Maven 3.1.0 having
seen it say (all you need is JDK 1.5 or higher) and try and build some code
and bomb out with "-source 1.6 is unknown" and say Maven is shit.

So as I see it. The Core plugins (i.e. the ones hosted at
org.apache.maven.plugins) or maybe the core plugins involved in the default
lifecycles, cannot assume Java higher than the minimum required to run the
Maven version they run on.

Core is still at 1.5. So therefore the highest default the compiler plugin
can consider at this point in time is 1.5.

I will -1 any change to that default above the min required by core unless
somebody gives a compelling argument for the change, and I do not see such
a compelling argument. (I am not saying I will -1 upping the min JDK
required by Maven, just that compiler's default cannot be higher than the
minimum version required by Maven)


On 30 November 2012 15:53, Stephen Connolly <
> wrote:

> Actually the current behaviour is 1.5 is using Maven Compiler Plugin 2.5
> or newer (might be 2.4 but I'd need to check)
> With Maven 3.1.0, the version of the Maven Compiler Plugin that you get if
> you have not locked down plugin versions will be upped to a version with
> this new default.
> So if you don't lock things down and live on the latest Maven, out of the
> box you will get Java 1.5 compatible classes until you lock things down.
> On 30 November 2012 15:35, Tim Pizey <> wrote:
>> On 30 November 2012 13:42, Aliaksei Lahachou wrote:
>> > Hello everyone,
>> >
>> > I'm am against updating default version to 1.7. My favourite option
>> would
>> > be to use the lowest possible version of JDK and give a warning if
>> version
>> > is not specified explicitly
>> I too am in favour of maintaining the current behaviour, explicit
>> declaration of version, or you get 1.3.
>> Explicit versioning is what Maven is all about!
>> cheers
>> Tim
>> --
>> Tim Pizey -
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail:
>> For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message