maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Walker <brett.wal...@geometryit.com>
Subject Re: Checkstyle Plugin: Upgrade dependency to Checkstyle v5.6
Date Tue, 13 Nov 2012 09:07:44 GMT
Hi Thomas,

>> I tried building the plugin myself with an updated dependency. It did not work.
>
>Have you tried overriding the plugin dependency with checkstyle:5.6?
>
><plugin>
>   <artifactId>maven-checkstyle-plugin</artifactId>
>   <version>2.9.1</version>
>   <dependencies>
>      <dependency>
>         <groupId>com.puppycrawl.tools</groupId>
>         <artifactId>checkstyle</artifactId>
>         <version>5.6</version>
>      </dependency>
>   </dependencies>
></plugin>

This is what I did. It fixed my immediate problem but introduced others. After fiddling around
for a while I could not resolve all the new problems.

I'm not familiar with Maven Plugin Architecture nor with how the Checkstyle Plugin links to
the Checkstyle Library.

I am hoping someone can point me in the right direction.

Brett
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message