maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Froggerbin" <frogger...@gmail.com>
Subject RE: MissingProjectException
Date Tue, 27 Nov 2012 16:42:41 GMT
That is the whole problem. The project is not in E:\. It's in E:\Dev\Apps\Java. Still I get
this error no matter where I put the project or open it from.

-----Original Message-----
From: Milos Kleint [mailto:mkleint@gmail.com] 
Sent: dinsdag 27 november 2012 14:11
To: Maven Users List
Subject: Re: MissingProjectException

I suggest you move the project from root E:\ to something like E:\projectA (thus the pom.xml
file will be at E:\projectA\pom.xml

Milos

On Tue, Nov 27, 2012 at 12:17 PM, Froggerbin <froggerbin@gmail.com> wrote:
> Hello,
>
>
>
> When I try to either Build, Clean and Build or Run (play button) my '
> <http://www.coderanch.com/forums/f-67/tools> Maven Webapplication' in 
> NetBeans, I get the following output:
>
>
>
> 1.      cd E:\Dev\Java\MyApp; "JAVA_HOME=E:\\Apps (x86)\\Dev\\Java\\jdk7u7"
> "M2_HOME=E:\\Apps (x86)\\Dev\\apachemaven\\apache-maven-3.0.4" 
> "\"E:\\Apps 
> (x86)\\Dev\\apachemaven\\apache-maven-3.0.4\\bin\\mvn.bat\"" clean install -e
> 2.      Error stacktraces are turned on.
> 3.      Scanning for projects...
> 4.
> ------------------------------------------------------------------------
> 5.      BUILD FAILURE
> 6.
> ------------------------------------------------------------------------
> 7.      Total time: 0.138s
> 8.      Finished at: Mon Oct 22 13:16:36 CEST 2012
> 9.      Final Memory: 2M/15M
> 10.
> ------------------------------------------------------------------------
> 11.     The goal you specified requires a project to execute but there is no
> POM in this directory (E:\). Please verify you invoked Maven from the 
> correct directory. -> [Help 1]
> 12.     org.apache.maven.lifecycle.MissingProjectException: The goal you
> specified requires a project to execute but there is no POM in this 
> directory (E:\). Please verify you invoked Maven from the correct directory.
>
> 13.         at
> org.apache.maven.lifecycle.internal.LifecycleStarter.execute(Lifecycle
> Starte
> r.java:89)
> 14.         at
> org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
> 15.         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
>
> 16.         at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
> 17.         at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
> 18.         at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
> 19.         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 20.         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.j
> ava:57
> )
> 21.         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccess
> orImpl
> .java:43)
> 22.         at java.lang.reflect.Method.invoke(Method.java:601)
> 23.         at
> org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launc
> her.ja
> va:290)
> 24.         at
> org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java
> :230)
>
> 25.         at
> org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.
> java:409)
> 26.         at
> org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:3
> 52)
> 27.
> 28.     Re-run Maven using the -X switch to enable full debug logging.
> 29.
> 30.     For more information about the errors and possible solutions, please
> read the following articles:
> 31.     [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MissingProjectExcepti
> on
>
>
> This is what I have tried to fix the problem:
>
> - Uninstalled NetBeans 7.2, removed .m2 directory, removed .nbi 
> directory (I don't know if this belongs to NetBeans), rebooted and 
> reinstalled NetBeans
> 7.2
> - Uninstalled NetBeans 7.2 and installed NetBeans 7.0.1
> - modified the POM file of the project
> - modify the context.xml file in META-INF/ folder of my project to 
> point it to a different path.
> - Correctly install Maven by adding the proper environment variables 
> (works)
>
>
> My projects used to build and run perfectly with no problems when I 
> was using NetBeans 7.0.1, until I installed NetBeans 7.2. That's when 
> I started getting this error.
> The error doesn't go away no matter what I try.
>
> Other strange behavior:
> - When I try to create a new Maven Webapplication in NetBeans, it 
> always creates it under the root of my drive E:\ in a folder even 
> though I explicitly tell it to install it under my projects folder.
>
> What works:
>
> -The only time when my projects successfully build and run is when I 
> run them in my Windows XP SP3 virtual machine.
> So I don't know what to think here. What application or configuration 
> is at fault? I find it very difficult to troubleshoot.
>
> -Running this command:
> <https://cwiki.apache.org/confluence/display/MAVEN/MissingProjectExcep
> tion> 
> https://cwiki.apache.org/confluence/display/MAVEN/MissingProjectExcept
> ion thus using an explicit path to my project I don't want to do this 
> every time. I want it to work like it's supposed to.
>
>
> Specs:
> JDK 1.7
> Sourcecode  <http://www.javaranch.com/> java version: 1.6
> OS: Windows 7 x64
> Server used: Tomcat 7.x / GlassFish 3.1.2
>
> Thank you,
>
> --
>
> William
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message