maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rolf Lear <j...@tuis.net>
Subject Recommendations to resolve artifact/version fubar
Date Mon, 28 May 2012 22:09:44 GMT
Hi all.

I maintain the JDOM project, and unfortunately it seems I made a 
'novice' error when deploying a new version of JDOM to maven-central.

Thus, the situation is as follows: 
http://search.maven.org/#browse|-1946144149

JDOM 2.x was released with a separate (new) package name for the express 
purpose of allowing the user to run both JDOM 1.x and 2.x in the same 
JVM. This works fine for non-maven users, but maven users are not able 
to have dependencies on both JDOM 1.1.3 and JDOM 2.0.1 simultaneously.

So, I have already been 'criticized' for the fact that this situation 
could have been avoided by using a different artifact id for the new 
JDOM 2.x releases... and I am not looking for more criticism... what I 
need is some insight as to what the correct procedure would be to do 
*now* to produce the best outcome.

How do I best resolve this situation?

Bear in mind that people use JDOM from all sorts of places... and JDOM 
1.x versions are dependencies of many other 'third-party' maven projects.

Rolf

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message