maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Hohwiller <jo...@j-hohwiller.de>
Subject Re: help needed: problems with eclipse, m2e and wst
Date Fri, 04 May 2012 07:25:34 GMT
Hi Daniel,

thank you for your help and response...

> You're talking about missing dependencies to libraries, not Maven modules, it
> that correct?

No. I mean internal dependencies to my own artefacts not external libraries.
Or in other words dependencies on eclipse projects.

> 
> Did you try going to Project Properties > Deployment Assembly ? 

Yes. This is where the "org.eclipse.wst.common.component" file is
configured. I can also fix my problem here by clicking "add" and then
"projects" and then selecting the missing projects.

I am absolutely and 100% sure that the missing projects are dependencies
of that WAR-packaging module/project. I also checked by "dependency hierarchy"
tab of the m2e POM view as well as with mvn dependency:tree.

> Is "Maven Dependencies" shown?

Yes, it is. However only if the project dependencies are also present,
it works.

Then IMHO this is a bug of m2e such that these maven dependencies are calculated
wrong or exclude the eclipse internal project dependencies
and those are calculated wrong by m2e-wtp.

> If not, click on Add > Java Build Path Entries > Maven
> Dependencies > Finish
> 
> Then, to be safe, remove the project from Tomcat in the Servers view, click
> Publish, and add the project to the Tomcat instance in the Servers view.

Unfortunately that's not the case.

> 
> HTH,
> Daniel Serodio

Best Regards
  Jörg

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message