maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Albou <yann-em...@club-internet.fr>
Subject Re: Filtering not working after at sign
Date Mon, 07 May 2012 08:31:48 GMT
Hello,

Sorry for being unclear...
In a simple maven jar project I have the following pom:
<project ...>
	<modelVersion>4.0.0</modelVersion>
	<groupId>org.test.mvn</groupId>
	<artifactId>mvnTestFiltering</artifactId>
	<packaging>jar</packaging>
	<name>mvnTestFiltering</name>
	<version>1.0.0-SNAPSHOT</version>
	<build>
		<resources>
			<resource>
				<filtering>true</filtering>
				<directory>src/main/resources</directory>
			</resource>
		</resources>
	</build>
</project>


and in dir "src/main/resources" I created a file "myResource.xml"
containing:
<?xml version="1.0" encoding="UTF-8"?>
<deployment xmlns="urn:jboss:bean-deployer:2.0">

	<bean name="${project.artifactId}_Listener1" class="org.test.MyClass">
		<annotation>@${project.artifactId}</annotation>
	</bean>

</deployment>


After executing mvn resources:resources the resulting "myResource.xml" in
"target/classes" dir is 

<?xml version="1.0" encoding="UTF-8"?>
<deployment xmlns="urn:jboss:bean-deployer:2.0">

	<bean name="mvnTestFiltering_Listener1" class="org.test.MyClass">
		<annotation>@${project.artifactId}</annotation>
	</bean>

</deployment>

The second "${project.artifactId}" has not been replaced because of the @
sign...
After reading http://maven.apache.org/shared/maven-filtering/ I saw token @@
are interpolated. I guess my issue could be link to this ?


Thanks
Yann.


--
View this message in context: http://maven.40175.n5.nabble.com/Filtering-not-working-after-at-sign-tp5689637p5690537.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message