maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pranay agarwal <streetfi...@gmail.com>
Subject how to check/change the jdk version used by maven
Date Fri, 20 Jan 2012 13:48:01 GMT
hi, i am using maven to compile some java classes .One of the classes has
an annotation(@Override) so when i run mvn compile then i get errror that:

 annotations are not supported in -source 1.3
(use -source 5 or higher to enable annotations)
        @Override

 annotations are not supported in
-source 1.3
(use -source 5 or higher to enable annotations)
        @Override

Although the java version in my system is jdk 1.6.29 still i can't
understand this error.
So i there a way by which i can check the jdk version maven is using and
perhaps change it.
Or, is there any other solution?
Thanks.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message