maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: Conflicting Spring versions
Date Thu, 15 Dec 2011 13:58:09 GMT
On Wed, Dec 14, 2011 at 3:17 PM, scabbage <guanshan@gmail.com> wrote:
> I have a multi-module project with a parent pom and several sub-modules. In
> one of the module, I have a dependency that has a transitive dependency of
> spring (2.0.6). How do I go about having the rest of my project using Spring
> 3.0.6.RELEASE?

If you absolutely, positively, need two copies of spring, you need two
class loaders. This isn't to do with Maven, it's to do with Java.

You could look into OSGi or Sisu.

>
> Thanks.
>
>
> --
> View this message in context: http://maven.40175.n5.nabble.com/Conflicting-Spring-versions-tp5075558p5075558.html
> Sent from the Maven - Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message