maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leon Rosenberg <rosenberg.l...@gmail.com>
Subject Using multiple repositories
Date Wed, 07 Sep 2011 15:20:08 GMT
Hello,

I have following question/problem.
We have some open source software and some commercial software. We use
two different repositories to host them:

(settings)


	<repositories>
		<repository>
			<id>provided</id>
			<url>http://nexus.anotheria.net/nexus/content/groups/public</url>
			<releases>
				<enabled>true</enabled>
			</releases>
			<snapshots>
				<enabled>true</enabled>
			</snapshots>
		</repository>
               <repository>
                   <id>anotheria-commercial</id>
                   <url>http://commercialurl/nexus/content/groups/public</url>
                   <releases>
                       <enabled>true</enabled>
                   </releases>
                   <snapshots>
                       <enabled>true</enabled>
                   </snapshots>
               </repository>
	</repositories>
i also have entries with passwords for both servers (the public one
only for publishing).
However, whenever I build mvn never downloads anything from the
"closed" repository, even the artifact is there.

Is this the right approach to have two repositories? (two physical servers).
Or should we have two repositories in one server (nexus).
Or should the closed repository proxy the open repository?

thanx in advance
Leon

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message