maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hahn, Christopher (SAN DIEGO)" <christopher.h...@hp.com>
Subject Not a valid plugin file: maven-taglib-plugin-1.4.2.jar
Date Tue, 20 Sep 2011 19:13:07 GMT
Hello all,

I have been asked to drive a legacy build for the first time,
and I am getting the error in the Subject above.

It is a Maven 1.0 build and supposedly has been working for
quite some time.

The console output of the action that has the error is here:
========================================================
E:\foo\bar\snark\main>maven -e jar:deploy
Maven options are
Maven options are -server -Xms400m -Xmx400m -XX:+UseConcMarkSweepGC -XX:+UseParNewGC
__  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0.2

Attempting to download buildtool-main-SNAPSHOT.jar.
org.apache.maven.MavenException: Not a valid plugin file: E:\foo\bar\snark\main\lib\maven-taglib\plugins\maven-taglib-plugin-1.4.2.jar
        at org.apache.maven.plugin.PluginManager.installPlugin(PluginManager.java:910)
        at org.apache.maven.plugin.PluginManager.installPlugin(PluginManager.java:862)
        at org.apache.maven.plugin.PluginManager.processDependencies(PluginManager.java:448)
        at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:642)
        at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
        at org.apache.maven.cli.App.doMain(App.java:488)
        at org.apache.maven.cli.App.main(App.java:1239)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at com.werken.forehead.Forehead.run(Forehead.java:551)
        at com.werken.forehead.Forehead.main(Forehead.java:581)

You have encountered an unknown error running Maven. Please help us to correct
this problem by following these simple steps:
- read the Maven FAQ at http://maven.apache.org/faq.html
- run the same command again with the '-e' parameter, eg maven -e jar
- search the maven-user archives for the error at
http://nagoya.apache.org/eyebrowse/SummarizeList?listName=users@maven.apache.org
- post the output of maven -e to JIRA at
http://jira.codehaus.org/BrowseProject.jspa?id=10030 (you must sign up first)
- run 'maven --info' and post the output as the environment to the bug above


Total time: 2 seconds
Finished at: Tue Sep 20 09:32:45 PDT 2011

E:\foo\bar\snark\main>
========================================================

I am just getting started on this, but wanted to check with the group
as to whether this is a common issue.

I found several copies of maven-taglib-plugin-1.4.2.jar on the system in question
and tried copying one into this location, but this produced the same error.

Does anyone recall this issue when working with Maven 1.0?

Thank you very much....just for reading this novella.  ;0)

Christopher

________________________________

[cid:image001.png@01CAF080.AD65F1E0]

Christopher Hahn
The Dude
SM Configuration Management
R&D Services, Hewlett-Packard
Phone: 858-655-4096
Cell: 619-630-9791
chahn@hp.com<mailto:christopher.hahn@hp.com>

Visit our SPE Portal<http://teams5.sharepoint.hp.com/teams/SPE/default.aspx>

________________________________




Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message