maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <and...@hammar.net>
Subject Re: Unable to download Maven 3 pom type dependency using Maven 2
Date Wed, 24 Aug 2011 14:40:40 GMT
I think I've seen similar issues reported with Artifactory. You should
check on the Artifactory list, but I think it was due to an old
Artifactory version or some setting in Artifactory.

/Anders

On Wed, Aug 24, 2011 at 16:02, Javed Mandary <javed2@gmail.com> wrote:
> Dear All,
>             I have an interesting case whereby I have an
> artifact com.my.groupid:myartifact:0.44-SNAPSHOT which I have uploaded on my
> organisation repo (Artifactory) using maven 3.x:
>
>
> <dependency>
> <groupId>com.my.groupid</groupId>
> <artifactId>my.artifact</artifactId>
> <version>0.44-SNAPSHOT</version>
> <scope>import</scope>
> <type>pom</type>
> </dependency>
>
> However when users who run maven 2.x (2.2.1) try to run a build where this a
> pom dependency it seems that maven 2 is unable to resolve the uploaded maven
> 3 dependency.
>
> Would any of you know why this is currently the case?
>
> many thanks,
>  Javed
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message