maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Wheeler <rwhee...@artifact-software.com>
Subject Re: Problem adding hibernate-jbosscache2 to my project
Date Wed, 10 Aug 2011 15:17:57 GMT
Someone else has a dependency on  
org.jboss.cache:jbosscache-core:jar:3.1.0.GA
You need to look at your dependency tree and exclude this from the 
package that is trying to add it in.

Ron

On 10/08/2011 11:08 AM, ccc wrote:
> My mistake - I copied too much from the console and included some older
> messages from when I was trying different solutions for my problem.
>
> I have now removed ALL dependencies from my pom. I get no errors.
>
> But as soon as I add just this dependency (nothing else):
>
> 		<dependency>
> 			<groupId>org.hibernate</groupId>
> 			<artifactId>hibernate-jbosscache2</artifactId>
> 			<version>3.3.2.GA</version>
> 			<type>jar</type>
> 			<scope>compile</scope>
> 		</dependency>
>
> I get:
>
> 10/08/11 17:04:33 CEST: Maven Builder: INCREMENTAL_BUILD requireFullBuild
> 10/08/11 17:04:33 CEST: [WARN] Using platform encoding (Cp1252 actually) to
> copy filtered resources, i.e. build is platform dependent!
> 10/08/11 17:04:33 CEST: [INFO] Copying 1 resource
> 10/08/11 17:04:33 CEST: [INFO] Nothing to compile - all classes are up to
> date
> 10/08/11 17:04:33 CEST: [WARN] Using platform encoding (Cp1252 actually) to
> copy filtered resources, i.e. build is platform dependent!
> 10/08/11 17:04:33 CEST: [INFO] Copying 0 resource
> 10/08/11 17:04:33 CEST: Maven Builder: INCREMENTAL_BUILD requireFullBuild
> 10/08/11 17:04:33 CEST: [WARN] Using platform encoding (Cp1252 actually) to
> copy filtered resources, i.e. build is platform dependent!
> 10/08/11 17:04:33 CEST: [INFO] Copying 0 resource
> 10/08/11 17:04:33 CEST: [INFO] Nothing to compile - all classes are up to
> date
> 10/08/11 17:04:33 CEST: [WARN] Using platform encoding (Cp1252 actually) to
> copy filtered resources, i.e. build is platform dependent!
> 10/08/11 17:04:33 CEST: [INFO] Copying 0 resource
> 10/08/11 17:04:33 CEST: Refreshing [/jump/pom.xml]
> 10/08/11 17:04:34 CEST: [WARN] The POM for
> org.jboss.cache:jbosscache-core:jar:3.1.0.GA is missing, no dependency
> information available
> 10/08/11 17:04:34 CEST: Missing artifact
> org.jboss.cache:jbosscache-core:jar:3.1.0.GA:compile
> 10/08/11 17:04:34 CEST: Missing artifact
> org.jboss.cache:jbosscache-core:jar:3.1.0.GA:compile
> 10/08/11 17:04:34 CEST: Missing artifact
> org.jboss.cache:jbosscache-core:jar:3.1.0.GA:compile
> 10/08/11 17:04:34 CEST: Missing artifact
> org.jboss.cache:jbosscache-core:jar:3.1.0.GA:compile
>
>
>
> --
> View this message in context: http://maven.40175.n5.nabble.com/Problem-adding-hibernate-jbosscache2-to-my-project-tp4685996p4686132.html
> Sent from the Maven - Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message