maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wurzelbert <jacek.marynow...@goerlitz.com>
Subject buildnumber-maven-plugin and service mix bundle
Date Fri, 01 Jul 2011 08:26:49 GMT
Hi,

I'm pretty new to SMX with maven and have a problem with the buildnumber
plugin in combination with osgi bundling.

My pom contains:
---
<parent>
                <groupId>org.apache.servicemix.features</groupId>
                <artifactId>features</artifactId>
                <version>4.3.0</version>
        </parent>
...
<packaging>bundle</packaging>
<version>1.0.${buildNumber}</version>
...
<plugin>
                                <groupId>org.codehaus.mojo</groupId>
                               
<artifactId>buildnumber-maven-plugin</artifactId>
                                <version>1.0</version>
                                <executions>
                                        <execution>
                                                <phase>validate</phase>
                                                <goals>
                                                <goal>create</goal>
                                                </goals>
                                                <configuration>
                                                       
<doCheck>false</doCheck>
                                                       
<doUpdate>true</doUpdate>
                                                       
<useLastCommittedRevision>true</useLastCommittedRevision>
                                                </configuration>
                                        </execution>
                                </executions>
                        </plugin>


While building the bundle I see in the console:
 [INFO] Storing buildNumber: 54 at timestamp: 1309442078694
so the plugins is getting the version number correctly but my jar file has
still the "${buildNumber}" thing in its name ...
I've been playing around with goals and phases without success.

I've also changed the packaging to jar and then it's working !!! but it
isn't an installable bundle for smx...
The param -DbuildNumber=123 is working too.

What is the problem? Please help me ! 

--
View this message in context: http://maven.40175.n5.nabble.com/buildnumber-maven-plugin-and-service-mix-bundle-tp4541357p4541357.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message