maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Olsen <itchyporcup...@gmail.com>
Subject Help!: Detected Maven Version is not in the allowed range
Date Sat, 25 Jun 2011 20:35:22 GMT
I'm reading a book about maven. The book appears to be somewhat outdated but
it hasn't been too difficult yet.

Anyways, I've created a project using the "simple" archetype. I have not
added or edited any files. I typed "mvn install" and the following was the
output:

[INFO] Scanning for projects...
[INFO] ------------------------------
------------------------------------------
[INFO] Building Unnamed -
org.sonatype.mavenbook.simple:simple:jar:1.0-SNAPSHOT
[INFO]    task-segment: [install]
[INFO]
------------------------------------------------------------------------
[INFO] [enforcer:enforce {execution: enforce-plugin-versions}]
[WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireMavenVersion
failed with message:
Detected Maven Version: 2.2.1 is not in the allowed range 3.0-RC1.
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Some Enforcer rules have failed. Look above for specific messages
explaining why the rule failed.
[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 3 seconds
[INFO] Finished at: Sat Jun 25 13:19:57 PDT 2011
[INFO] Final Memory: 14M/85M
[INFO]
------------------------------------------------------------------------

What is the problem and how can I solve it?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message