maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Remijan <mjremi...@yahoo.com>
Subject Re: Why can't 'mvn site' find a grand-parent pom?
Date Fri, 03 Jun 2011 16:35:20 GMT
Ok, so I am trying to use version 3.0-beta-3 and Maven is acting so inconsistently I can't
make any sense of what's going on. 


When I execute `mvn site` I see the following which indicates Maven is not getting the correct
version of the plugin.


     [INFO] --- maven-site-plugin:2.1:site (default-site) @ ferris-bible-jmce ---

When I grep through `mvn help:effective-pom` I see the wrong version number...

       <plugin>
         <artifactId>maven-site-plugin</artifactId>
         <version>2.1</version>
         <executions>
           <execution>
             <phase>prepare-package</phase>
             <goals>
           </goals>
         </execution>
       </executions>
     </plugin>

But when I execute `mvn help:describe -Dplugin=site` it shows the correct version!!!

     Group Id: org.apache.maven.plugins
     Artifact Id: maven-site-plugin
     Version: 3.0-beta-3

This is completely frustrating and I have no idea what's going on.

Any other thoughts?




________________________________
From: Dennis Lundberg <dennisl@apache.org>
To: Maven Users List <users@maven.apache.org>
Sent: Wednesday, June 1, 2011 3:34 PM
Subject: Re: Why can't 'mvn site' find a grand-parent pom?

On 2011-06-01 16:18, Michael Remijan wrote:
> I'm using Maven 3.0.2 and when I execute 'mvn site' I get errors saying Maven cannot
find one of my pom files.  The error is:
> 
> [INFO] --- maven-site-plugin:2.1:site (default-site) @ ferris-bible-jmce ---

Note that maven-site-plugin 2.1 is not compatible with Maven 3. Please
use version 3.0-beta-3.

> Downloading: http://repo1.maven.org/maven2/org/ferris/ferris-standard-project/0.0.2/ferris-standard-project-0.0.2.pom
> [INFO] Unable to load parent project from a relative path: 1 problem was encount
> ered while building the effective model for org.ferris:ferris-bible-parent:0.0.4

This is a standard error message in Maven 3. It occurs when Maven is
building a project and cannot find the parent of the project using
<parent> / <relativePath>. See

https://cwiki.apache.org/confluence/display/MAVEN/Maven+3.x+Compatibility+Notes#Maven3.xCompatibilityNotes-ParentPOMResolution

> I have 2 questions:
> 1) Why isn't Maven looking for the file in .m2/repository/ ?  The POM is already there.
> 
> 2) Why is Maven only look in "http://repo1.maven.org/maven2" for the pom and not look
through the rest of <repository> entries in my settings.xml? 


-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message