maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From samwun <leiwun2...@gmail.com>
Subject My maven settings doesn't read local Nexus repositories
Date Sun, 12 Jun 2011 05:13:17 GMT
Hello,

I have setup Nexus in localhost:8081 and have setup settings.xml in
c:/User/sam/.m2/ folder.
But my maven project still trying to call maven repository from the
internet, as shown below:

11-6-12 下午02时32分42秒: Downloaded
http://repo1.maven.org/maven2/javax/transaction/jta/1.0.1B/jta-1.0.1B.pom
11-6-12 下午02时32分42秒: Missing artifact org.hsqldb:hsqldb:jar:1.8.0.10:compile
11-6-12 下午02时32分42秒: Missing artifact
org.hibernate:hibernate-annotations:jar:3.3.1.GA:compile
11-6-12 下午02时32分42秒: Missing artifact
org.hibernate:hibernate:jar:3.2.6.ga:compile
11-6-12 下午02时32分42秒: Missing artifact
net.sf.ehcache:ehcache:jar:1.2.3:compile
11-6-12 下午02时32分42秒: Missing artifact asm:asm-attrs:jar:1.5.3:compile
11-6-12 下午02时32分42秒: Missing artifact dom4j:dom4j:jar:1.6.1:compile
11-6-12 下午02时32分42秒: Missing artifact antlr:antlr:jar:2.7.6:compile
11-6-12 下午02时32分42秒: Missing artifact cglib:cglib:jar:2.1_3:compile
11-6-12 下午02时32分42秒: Missing artifact asm:asm:jar:1.5.3:compile
11-6-12 下午02时32分42秒: Missing artifact
commons-collections:commons-collections:jar:2.1.1:compile
11-6-12 下午02时32分42秒: Missing artifact
org.hibernate:hibernate-commons-annotations:jar:3.0.0.ga:compile
11-6-12 下午02时32分42秒: Missing artifact
org.hibernate:ejb3-persistence:jar:1.0.1.GA:compile
11-6-12 下午02时32分42秒: Missing artifact
commons-logging:commons-logging:jar:1.0.4:compile
11-6-12 下午02时32分42秒: Missing artifact
org.aspectj:aspectjrt:jar:1.6.6:compile
11-6-12 下午02时32分42秒: Missing artifact
javax.servlet:servlet-api:jar:2.5:provided
11-6-12 下午02时32分42秒: Missing artifact junit:junit:jar:3.8.1:test
11-6-12 下午02时32分43秒: Maven Builder: AUTO_BUILD 
11-6-12 下午02时32分55秒: Maven Builder: AUTO_BUILD requireFullBuild
11-6-12 下午02时32分55秒: Build errors for mvnproject-core;
org.apache.maven.project.ProjectBuildingException: Some problems were
encountered while processing the POMs:
[ERROR] Malformed POM C:\work\MvnProj\mvnproject-core\pom.xml: Unrecognised
tag: 'exclusions' (position: START_TAG seen ...</properties>\r\n  \r\n  
<exclusions>... @48:16)  @ C:\work\MvnProj\mvnproject-core\pom.xml, line 48,
column 16

The settings.xml file in C:\User\Sam\.m2\ directory is shown below:

<repositories>
		<repository>
		  <id>central</id>
		  <url>http://localhost:8081/nexus/content/groups/public/</url>
		  <snapshots>
			<enabled>false</enabled>
		  </snapshots>
		</repository>
		<repository>
		  <id>snapshots</id>
		  <url>http://localhost:8081
		  /nexus/content/groups/public-snapshots/</url>
		  <releases>
			<enabled>false</enabled>
		  </releases>
		</repository>
	  </repositories>
	  <pluginRepositories>
		<pluginRepository>
		  <id>central</id>
		  <url>http://localhost:8081/nexus/content/groups/public/</url>
		  <snapshots>
			<enabled>false</enabled>
		  </snapshots>
		</pluginRepository>
		<pluginRepository>
		  <id>snapshots</id>
		  <url>http://localhost:8081/nexus/content/groups/public-snapshots/</url>
		  <releases>
			<enabled>false</enabled>
		  </releases>
		</pluginRepository>
	  </pluginRepositories>


Can anybody tell me how to troubleshoot this error? I  just don't know why
my maven can't reference the repositories in my localhost Nexus server.

Your suggestion is very much appreciated.

Thanks
Sam



--
View this message in context: http://maven.40175.n5.nabble.com/My-maven-settings-doesn-t-read-local-Nexus-repositories-tp4480991p4480991.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message