maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rui Vil√£o <rpvi...@gmail.com>
Subject Using the new maven assembly goals
Date Fri, 11 Mar 2011 16:27:51 GMT
Hi all,

I've been using the maven-assembly-plugin for long time and I noticed that
some goals changed and are now deprecated.

I've a multi-module project and I only want to run the assembly plugin on
the parent. But if I run assembly:single (according to the plugin's page is
the only one that is not deprecated) it will try to run on every module and
I get this:

[INFO]
------------------------------------------------------------------------
[INFO] Building apis
[INFO]    task-segment: [assembly:single]
[INFO]
------------------------------------------------------------------------
[INFO] [assembly:single {execution: default-cli}]
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error reading assemblies: No assembly descriptors found.

I set the inherited tag to false in the plugin's declaration like:

      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-assembly-plugin</artifactId>
        <inherited>false</inherited>
        <configuration>
          <descriptors>
            <descriptor>release.xml</descriptor>
          </descriptors>
        </configuration>
      </plugin>

With no luck.
Anyone knows how do I stop this plugin of going recursively to all modules?

Thanks in advance,

Rui

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message