maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ewerton Vale Leal <ewerto...@gmail.com>
Subject Re: Help to use plugin coverage
Date Fri, 18 Feb 2011 19:06:59 GMT
I did what you recommended and did not work.
The cargo and selenium plugins must be executed before run the coverage .
When I execute the install the coverage does not work and when I execute
 the coverage, the cargo , selenium and unit tests don’t execute.
I’m sending in annex the log of install execution and coverage.



2011/2/18 Hilco Wijbenga <hilco.wijbenga@gmail.com>

> On 18 February 2011 04:06, Ewerton Vale Leal <ewertonlv@gmail.com> wrote:
> > Hello, I need a help to setting maven. I wanna use the
> > plugin-coverage-maven-plugin to analyse the coverage of functional tests.
> > I use also the cargo plugins, selenium and surefire. Without using these
> > plugins,  I can do the coverage of unit tests with no problem.
> > But with functional tests does not work.
> > I also use  Hudson for continuous integration.
> > I'm sending in annex my pom.xml
> > Sorry, my english isn't very good.
> > My Pom.xml below and in annex.
>
> <snip/>
>
> > <plugin>
> > <groupId>org.codehaus.mojo</groupId>
> > <artifactId>cobertura-maven-plugin</artifactId>
> > <version>2.4</version>
> > <executions>
> > <execution>
> > <id>instrument</id>
> > <phase>site</phase>
> > <goals>
> > <goal>cobertura</goal>
> > </goals>
> > </execution>
> > </executions>
> > </plugin>
>
> I'm guessing this is your problem. The "site" phase seems like the
> wrong place to run Cobertura. I'd try removing the entire <executions>
> part.
>



-- 
Ewerton Leal Vale
Bacharelando em Ciência da Computação - UFPI

Mime
View raw message