maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <and...@hammar.net>
Subject Re: No surefire-reports directory and BuildFailureException
Date Wed, 03 Nov 2010 09:12:44 GMT
Weird. But executing
mvn clean test -X
will give you debug output and should give you some kind of hint what's
wrong.
At least, it will tell you which plugin is running into trouble (I believe
it's the surefire-plugin based on your mail).

You could also try skipping tests to narrow things down. There are several
different ways:
mvn clean test -DskipTests
which will compile the tests but not execute them
mvn clean test -Dmaven.test.skip=true
which will even skip compilation of tests and some other related tasks

Doing "clean" in all steps is just to ensure a full build now when you are
having troubles. You shouldn't do this normally for every execution.
You could also delete your local repo to ensure there's nothing there
causing trouble.

/Anders

On Wed, Nov 3, 2010 at 08:02, Moritz Winter
<moritz.a.winter@googlemail.com>wrote:

> Hi,
>
>
> First of all I would like to mention that this is my first post on this
> list, I hope that this question is posted in the right place. I have tried
> finding a solution for my problem, but it either doesn't exist, or my
> limited brain can't manage to figure out how to do it (I strongly hope it is
> the latter).
>
> If I call "mvn test" on a project of mine, the last lines show me the
> BuildFailureExeception and "Please refer to [..]/target/surefire-reports for
> the individual test results."
> Problem is, there isn't a directory "surefire-reports" in the target of the
> project. Adding -e and -X, trying -Dmaven.test.failure.ignore=true generated
> a empty report and -Dsurefire.useFile=false didnt help either. Any
> suggestions how to get to the root cause of the error?
>
> Used version is surefire 2.6, but i did try 2.2 - 2.6 and none worked!
>
> Project: http://rapidshare.com/files/428614057/arquillian-example.zip
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message