maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Sansoucy <patrick.sanso...@gmail.com>
Subject Re: Maven 3.0 doesn't update snapshot artifacts
Date Fri, 26 Nov 2010 03:04:55 GMT
We witnessed the same issue here at work. While the latest Maven 2
works properly, our developpers using Maven 3 had the problem and had
to go through the same procedure of deleting the jar within the local
repo.

We, on the other hand, use archiva for our artifact deployement.
It is a major blocker for our dev team to upgrade to M3. I don't know
the culprit and I have not tried using the uniqueVersion toggle to
timestamp the snapshot, since I need to discuss this change with our
CM's.

-Patrick

On Tue, Nov 23, 2010 at 9:43 AM, Moser, Christian <cmo@metrohm.com> wrote:
> I'm unable to download the newest artifacts (compiled jar) with maven
> 3.0 and 3.0.1-RC1  from cmd line. The artifacts were deployed to
> artifactory 2.3.1.
>
>
>
> After calling "mvn -U" on a dependend artifact, maven just updates the
> metadata, but doesn't override the old artifacts contained in the local
> repository. I have to delete the local repository to receive the newest
> artifacts from remote after calling mvn -U. the artifacts are all
> snapshots version.
>
> Is there another, new way to force update snapshots?
>
>
>
> -Chris
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message