maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Problem with release plugin versions
Date Wed, 17 Nov 2010 22:50:09 GMT
Try mvn help:effective-pom to see if you've locked in the version.

Otherwise, we would need to know if you were using a repository manager.

- Brett

On 18/11/2010, at 7:38 AM, Todd Nine wrote:

> Hi all,
>  This morning I attempted to perform a release using maven v 2.2.1
> (r801777; 2009-08-07 07:16:01+1200).  Maven downloaded new versions of
> all my plugins, and now I receive the following error when trying to
> perform a mvn release:prepare mvn release:perform
> 
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Internal error in the plugin manager executing goal
> 'org.apache.maven.plugins:maven-release-plugin:2.0-beta-8:prepare':
> Unable to load the mojo
> 'org.apache.maven.plugins:maven-release-plugin:2.0-beta-8:prepare' in
> the plugin 'org.apache.maven.plugins:maven-release-plugin'. A required
> class is missing: org/jdom/filter/Filter
> org.jdom.filter.Filter
> 
> 
> 2.1 is the current version for the "release" plugin.  I haven't touched
> my pom nor any of my settings.xml files.  Any idea why maven now things
> that 2.0-beta8 is the latest?
> 
> Thanks,
> 
> 
> todd 
> SENIOR SOFTWARE ENGINEER
> 
> 
> 
> 
> 
> 
> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message