maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evgeny Goldin <evge...@gmail.com>
Subject "An API incompatibility was encountered" for using "plexus-utils"
Date Mon, 15 Nov 2010 09:46:16 GMT

Hi, one of my Maven plugins is using "org.codehaus.plexus:plexus-utils:2.0.5"
as follows:

org.codehaus.plexus.util.FileUtils.getDefaultExcludes()

to get a list of default exclude files patterns, like "**/CVS".
When I use this plugin and build the project with Maven 3 I get the
following error:


[ERROR] ...
An API incompatibility was encountered while executing
com.goldin.plugins:maven-copy-plugin:0.2-SNAPSHOT:
copy:
java.lang.NoSuchMethodError:org.codehaus.plexus.util.FileUtils.getDefaultExcludes()[Ljava/lang/String;


Seems like Maven 3 doesn't like me using "plexus-utils". What is alternative
possible? And what are the reasons for this error?

Thank you!

-----
Best regards,
Evgeny
http://evgeny-goldin.com/

-- 
View this message in context: http://maven.40175.n5.nabble.com/An-API-incompatibility-was-encountered-for-using-plexus-utils-tp3265343p3265343.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message