maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jo Support <jo.supp...@gmail.com>
Subject Re: versions plugin - "set" goal question
Date Thu, 07 Oct 2010 09:46:01 GMT
thanks a lot, it works

regards

On Wed, Oct 6, 2010 at 5:03 PM, Stephen Connolly
<stephen.alan.connolly@gmail.com> wrote:
> you need to add -DoldVersion=1.0
>
> On 6 October 2010 15:24, Jo Support <jo.support@gmail.com> wrote:
>> I'm a bit puzzled by versions plugin. According to versions:set goal's
>> documentation, reading the description it "sets the current project
>> version, updating the details of any child modules as necessary", and
>> it does.
>>
>> But in optional parameters, we can see the "artifactId" parameter,
>> that specify "the artifact id of the dependency/module to update".
>>
>> What I understand is that it looks inside dependencies of the project
>> for that artifact id, setting the version for that dependency.
>> By example, having this pom
>>
>> ...
>> <dependencyManagement>
>>        <dependencies>
>>                ...
>>                <dependency>
>>                        <groupId>org.myFramework</groupId>
>>                        <artifactId>myLibrary</artifactId>
>>                        <version>1.0</version>
>>                </dependency>
>>                ...
>>        </dependencies>
>> </dependencyManagement>
>> ...
>>
>> and executing
>>
>> mvn versions:set -DnewVersion=2.0 -DgroupId=org.myFramework
>> -DartifactId=myLibrary
>>
>> I expect to see a new pom content, like the following one
>>
>> ...
>> <dependencyManagement>
>>        <dependencies>
>>                ...
>>                <dependency>
>>                        <groupId>org.myFramework</groupId>
>>                        <artifactId>myLibrary</artifactId>
>>                        <version>2.0</version>
>>                </dependency>
>>                ...
>>        </dependencies>
>> </dependencyManagement>
>> ...
>>
>> but it does not.
>> It just says nothing, just terminates with a "BUILD SUCCCESFULL"
>> message and nothing more.
>>
>> Any clue?
>> Am I doing something wrong?
>> There is another way to do what I'm trying to do?
>>
>> Thanks a lot
>> Jo
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: users-help@maven.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message