maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hilco Wijbenga <hilco.wijbe...@gmail.com>
Subject Re: Maven 2 & 3 + Hudson + Nexus
Date Mon, 11 Oct 2010 15:40:13 GMT
On 6 October 2010 15:34, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
> On 5 October 2010 09:48, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
>> On 5 October 2010 04:09, Benjamin Bentmann <benjamin.bentmann@udo.edu> wrote:
>>> Hilco Wijbenga wrote:
>>>>       <repositories>
>>>>         <repository>
>>>>           <id>central</id>
>>>>           <url>http://central</url>
>>>>           <releases>
>>>>             <enabled>true</enabled>
>>>>           </releases>
>>>>           <snapshots>
>>>>             <enabled>true</enabled>
>>>>           </snapshots>
>>>>         </repository>
>>>>       </repositories>
>>>
>>> From this, it appears to be a bug in Maven 2 since your mirror should be
>>> contacted for snapshots.
>>>
>>>> What would get Maven to "disable repository central"?
>>>
>>> Might be something goes wrong with the override of central which prevents
>>> the snapshots=true policy from being applied.
>>
>> Okay, some more information. I tried it after having removed the
>> entire com/xyz directory: Maven (2.2.1) downloads two POMs, one
>> release and one snapshot before failing to download the
>> test-dependencies-pom again.
>>
>> Note how it first downloads the 0.0.7-SNAPSHOT POM for xyz-project
>> just before logging "Skipping disabled repository central".
>>
>> [DEBUG] Connecting to repository: 'all-mirror' with url:
>> 'http://www.xyz.com/nexus/content/groups/public'.
>> Downloading: http://www.xyz.com/nexus/content/groups/public/com/xyz/lp/xyz-project/0.0.7-SNAPSHOT/xyz-project-0.0.7-20101002.070000-2.pom
>> [DEBUG] attempting to create parent directories for destination:
>> xyz-project-0.0.7-20101002.070000-2.pom.tmp
>> 4K downloaded  (xyz-project-0.0.7-20101002.070000-2.pom)
>> [DEBUG] Using Wagon implementation lightweight from default mapping
>> for protocol http
>> [DEBUG]   Artifact resolved
>> [DEBUG] Skipping disabled repository central
>> [DEBUG] test-dependencies-pom: using locally installed snapshot
>> [DEBUG] Skipping disabled repository central
>> [DEBUG] Using mirror: http://www.xyz.com/nexus/content/groups/public
>> (id: all-mirror)
>>
>> Maven thinks it has already downloaded test-dependencies-pom? Would
>> "Artifact resolved" refer to test-dependencies-pom or simply to
>> xyz-project? Is this related to Wagon? Or is there "incorrect"
>> metadata in my remote repository (where "incorrect" means, correct for
>> Maven 3 but unpalatable to Maven 2)?
>
> I thought I'd give it another try but this time without an existing
> local repository. The result is exactly the same as before (see
> above). Lots of POMs are downloaded (from my mirror), then
> xyz-project's POM is downloaded successfully and Maven fails to find
> the test-dependencies-pom POM.
>
> I've created and attached a Bash script that sets up a local
> environment (in the directory where you install show-problem.sh) and
> then runs three Maven commands. The third one displays the problem I'm
> seeing. I think it may have to do with distributionManagement and
> scope import.
>
> I hope this will help to resolve this issue. At least now you should
> be able to see exactly what I'm seeing.

Would someone please try this and tell me whether I did something
wrong or hit a Maven 2 bug?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message