maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haszlakiewicz, Eric" <EHAS...@transunion.com>
Subject RE: Problem unpacking dependencies
Date Fri, 01 Oct 2010 22:09:36 GMT
>-----Original Message-----
>From: Phillip Hellewell [mailto:sshock@gmail.com]
>
>On Fri, Oct 1, 2010 at 3:52 PM, Haszlakiewicz, Eric
><EHASZLA@transunion.com> wrote:
>>
>> Do you have the right type specified in your
>/project/dependencies/dependency element?  If you're trying to unpack a zip
>type dependency it needs to be listed as such in both the dependency
>element and the plugin configuration.
>
>The dependency uses packaging type is "pom", but when deployed it
>includes both a .pom and a .zip because I use the assembly plugin to
>package up some stuff into a zip.
>
>I've tried specifying both <type>pom</type> and <type>zip</type>
in my
>plugin configuration and no matter what I get that error, because
>apparently it is trying to unpack the pom file.

I'm talking about the dependency section in the pom.xml file where you're trying to unpack
your artifact.  It doesn't matter if the pom.xml of your artifact has an overall packaging
of pom, if you're using the assmbly plugin it's going to deploy an additional artifact of
type zip.
You don't need to specify a type in the plugin configuration at all.  Just let it pick up
whatever you specify in your <dependency> element.

eric

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message