maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kenneth McDonald <kenneth.m.mcdon...@sbcglobal.net>
Subject Solution to scalatest "test" phase under maven
Date Tue, 28 Sep 2010 20:10:59 GMT
For some reason, the message below didn't get sent to the scala users or maven users list--at
least, not as far as my inbox is concerned :-) So I'm sending it again, in the hopes of helping
people who might find themselves in the situation I was in. Sorry if this is a repeat in your
mailbox.

Ken

> 
> Posting this in hopes it will help others. First, I'd like to heartily thank everyone
who gave of their time with helping me in this problem. I learned a log about maven (more
than I really want to :-) but it's good for future jobs), and I wouldn't have found the solution
on my own without a _lot_ more time.
> 
> Basically, a couple of people sent me pom files which worked for them, but which didn't
work for me. I don't know why, this is still a mystery. What did work was the following highlighted
line:
> 
>      <plugin>
>        <groupId>org.apache.maven.plugins</groupId>
>        <artifactId>maven-surefire-plugin</artifactId>
>        <version>2.6</version>
>        <configuration>
>            <useManifestOnlyJar>false</useManifestOnlyJar>  <----
>          <includes>
>            <include>**/*Test.*</include>
>            <include>**/*Suite.*</include>
>          </includes>
>        </configuration>
>      </plugin>
> 
> I'm going to have to dig into the Maven documentation and refresh my memory of manifests
(its been _years_ since I've used Java) to figure out exactly what is going on, but once I
added this, my tests ran smoothly. (And I am happy to say, all are still OK :-) ).
> 
> Again, many thanks to all,
> Ken McDonald


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message