maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Baptiste MATHUS ...@batmat.net>
Subject Re: How does maven resolve the plugin version to be used when outside a project
Date Mon, 13 Sep 2010 09:37:08 GMT
I also said I know the full form... :)
Thanks

2010/9/13 Thomas Markus <t.markus@proventis.net>

>  Hi,
>
> try something like
>
> mvn org.apache.maven.plugins:maven-help-plugin:2.1:describe -Dplugin=help
>
> regards
> Thomas
>
>
> Am 13.09.2010 10:59, schrieb Baptiste MATHUS:
>
>  Hi all,
>>
>> I'm currently trying to manually run dependency:get, but it doesn't work
>> since maven is trying to use 2.0 plugin version (ang "get" mojo came with
>> 2.1).
>>
>> Apart from using the full form command, how does maven decide which
>> version
>> to use for a plugin? Does it use the version defined in super-pom or
>> something else? If possible, how to (re)define that it should use 2.1
>> instead of 2.0?
>>
>> Thanks in advance.
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>


-- 
Baptiste <Batmat> MATHUS - http://batmat.net
Sauvez un arbre,
Mangez un castor !

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message