maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Getting Error - Couldn't find a version in [11.0] to match range [9.0,11.0)
Date Thu, 12 Aug 2010 15:59:46 GMT
Seems the weblogic plugin doesn't support version 11.0 (it is looking for 9.0 <= version
< 11.0)

On 13/08/2010, at 1:26 AM, Arunkumar wrote:

> 
> Hi,
> 
> I am trying to automate the Weblogic deployment using Maven. I am using
> Weblogic 11g.
> Here is my pom.xml
>                       <plugin>
> 			    <groupId>org.codehaus.mojo</groupId>
> 			    <artifactId>weblogic-maven-plugin</artifactId>
> 			    <version>2.9.1</version>
> 			    <executions>
> 			        <execution>
> 			            <phase>deploy</phase>
> 			            <goals>
> 			                <goal>deploy</goal>
> 			                <goal>start</goal>
> 			            </goals>
> 			        </execution>
> 			    </executions>
> 			    <configuration>
> 			        <name>dataselector-web</name>
> 			        <adminServerHostName>localhost</adminServerHostName>
> 			        <adminServerPort>7001</adminServerPort>
> 			        <adminServerProtocol>t3</adminServerProtocol>
> 			        <userId>admin</userId>
> 			        <password>Password1234$</password>
> 			        <upload>true</upload>
> 			        <remote>true</remote>
> 			        <verbose>false</verbose>
> 			        <debug>false</debug>
> 			        <targetNames>myserver</targetNames>
> 			        <noExit>true</noExit>
> 			    </configuration>
> 			    <dependencies>
> 			        <dependency>
> 			            <groupId>weblogic</groupId>
> 			            <artifactId>wlfullclient</artifactId>
> 			            <version>${weblogic.version}</version>
> 			        </dependency>
> 			        <dependency>
> 			            <groupId>weblogic</groupId>
> 			            <artifactId>com.bea.core.descriptor.wl</artifactId>
> 			            <version>1.1.0.0</version>
> 			            <scope>provided</scope>
> 			        </dependency>
> 			    </dependencies>
> 			</plugin>
> 
> I am using the following mvn istall cmds
> mvn install:install-file -DgroupId=weblogic
> -DartifactId=com.bea.core.descriptor.wl -Dversion=1.1.0.0 -Dpackaging=jar
> -Dfile=C:\Documents\wls1033_dev\modules\com.bea.core.descriptor.wl_1.3.2.0.jar
> 
> mvn install:install-file -DgroupId=weblogic -DartifactId=wlfullclient
> -Dversion=11.0 -Dpackaging=jar
> -Dfile=C:\Documents\wls1033_dev\wlserver\server\lib\wlfullclient.jar
> 
> mvn install:install-file -DgroupId=weblogic -DartifactId=weblogic
> -Dversion=11.0 -Dpackaging=jar
> -Dfile=C:\Documents\wls1033_dev\wlserver\server\lib\weblogic.jar
> 
> The error msg is: 
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> 
> Couldn't find a version in [11.0] to match range [9.0,11.0)
>  weblogic:weblogic:jar:null
> 
> from the specified remote repositories:
>  central (http://repo1.maven.org/maven2),
>  codehaus.org (http://repository.codehaus.org),
>  snapshots (http://snapshots.repository.codehaus.org)
> 
> Path to dependency:
>        1) org.codehaus.mojo:weblogic-maven-plugin:maven-plugin:2.9.1
> 
> 
> 
> Pls let me know where am i going wrong. 
> 
> TIA
> 
> 
> 
> -- 
> View this message in context: http://maven.40175.n5.nabble.com/Getting-Error-Couldn-t-find-a-version-in-11-0-to-match-range-9-0-11-0-tp2473346p2473346.html
> Sent from the Maven - Users mailing list archive at Nabble.com.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message