maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rusty Wright <rwright.li...@gmail.com>
Subject Re: axis2-wsdl2code maven plugin
Date Wed, 05 May 2010 22:50:38 GMT
Sorry, ignore this; I am sure I'm doing something wrong because this is happening when I'm
setting up one of the value objects.


On 2010-05-05 14:22, Rusty Wright wrote:
> I had the resource directory wrong so I've gotten past that part.  Now
> when I run my simple test it blows up with
>
> org.apache.xmlbeans.XmlException: error: Unexpected element: CDATA
> at org.apache.xmlbeans.impl.store.Locale$SaxLoader.load(Locale.java:3486)
> at org.apache.xmlbeans.impl.store.Locale.parse(Locale.java:712)
> at org.apache.xmlbeans.impl.store.Locale.parseToXmlObject(Locale.java:696)
> at org.apache.xmlbeans.impl.store.Locale.parseToXmlObject(Locale.java:683)
> at
> org.apache.xmlbeans.impl.schema.SchemaTypeLoaderBase.parse(SchemaTypeLoaderBase.java:208)
>
> at
> gov.weather.www.forecasts.xml.dwmlgen.wsdl.ndfdxml_wsdl.LatLonListZipCodeDocument$Factory.parse(LatLonListZipCodeDocument.java:99)
>
> at
> com.objecteffects.wwd.ndfd.LatLonListZipCodeXmlBeansTest.testLatLonListZipCode(LatLonListZipCodeXmlBeansTest.java:18)
>
>
> If anyone has any ideas I'd be grateful for feedback.
>
> Thanks
>
>
> On 2010-05-04 17:00, Rusty Wright wrote:
>> I'm trying to use this maven plugin and it's generating the XmlBeans
>> files properly, as far as I can tell, but when I try and run a minimal
>> unit test it's blowing up with a missing class, TypeSystemHolder, error.
>>
>> Caused by: java.lang.RuntimeException: Cannot load SchemaTypeSystem.
>> Unable to load class with name
>> schemaorg_apache_xmlbeans.system.s6521BFF385898FE194BCD5545E7D0165.TypeSystemHolder.
>>
>> Make sure the generated binary files are on the classpath.
>>
>> That class file exists and the path to that file is
>>
>> ${project.basedir}/target/generated-sources/axis2/wsdl2code/resources/schemaorg_apache_xmlbeans/system/s6521BFF385898FE194BCD5545E7D0165/TypeSystemHolder.class
>>
>>
>>
>> The long hex part changes when I do a "mvn clean test".
>>
>> It seems to me that I ought to be able to add that file or one of its
>> parent directories to the classpath by fixing my maven pom.xml but
>> nothing I've done has helped.
>>
>> Here's what I tried:
>>
>> <build>
>> <resources>
>> <resource>
>> <directory>${project.build.outputDirectory}/generated-sources/axis2/wsdl2code/resources/schemaorg_apache_xmlbeans</directory>
>>
>>
>>
>> <filtering>false</filtering>
>> </resource>
>> </resources>
>>
>> Can anyone offer some help?
>>
>> Here's the relevant plugin section from my pom.xml:
>>
>> <build>
>> <plugins>
>> <plugin>
>> <groupId>org.apache.axis2</groupId>
>> <artifactId>axis2-wsdl2code-maven-plugin</artifactId>
>>
>> <version>${version.axis2}</version>
>>
>> <executions>
>> <execution>
>> <goals>
>> <goal>wsdl2code</goal>
>> </goals>
>>
>> <configuration>
>> <wsdlFile>${project.basedir}/src/main/resources/ndfdXML.wsdl</wsdlFile>
>>
>> <databindingName>xmlbeans</databindingName>
>> </configuration>
>> </execution>
>> </executions>
>> </plugin>
>> </plugins>
>>
>> Thanks
>>
>>
>

-- 
0x2B | ~0x2b  --  Hamlet

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message