maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wale12 <chris.w...@ontario.ca>
Subject Re: Ear Plugin Version 5 issue
Date Fri, 14 May 2010 16:01:25 GMT

Fair point. 

I am using hudson so this is all I get.

Deployment descriptor:
D:\Hudson\jobs\HCV_1.0_Dev\workspace\hud_HCV_1.0_view1\UcmVob08A\Src_Java\HCVWebService\HCVServiceEAR\target\HCVServiceEAR\META-INF\application.xml
does not exist.


C.


snicoll wrote:
> 
>>uh? Why on Earth would you do this:
> 
>><earSourceDirectory>.</earSourceDirectory>
> 
>>Can you post the full stacktrace. Are you running from the reactor when it
>>happens?
> 
>>S.
> 
> 
>>On Fri, May 14, 2010 at 4:21 PM, Wale12 <chris.wale@ontario.ca> wrote:
> 
>>
>> I have a weird issue with a project I have.  I am using maven 2 and
>> version
>> 2.4.1 of the ear plugin and am using the version 5 no application.xml
>> options for packing the ear.
>>
>> <plugin>
>>   <artifactId>maven-ear-plugin</artifactId>
>>   <version>2.4.1</version>
>>   <configuration>
>>        <version>5</version>
>>        <generateApplicationXml>false</generateApplicationXml>
>>        <earSourceDirectory>.</earSourceDirectory>
>>
>>
>> <earSourceExcludes>pom.xml,pom.properties,.settings\,lib\,target\,.project</earSourceExcludes>
>>
>>
>> <finalName>${project.artifactId}-${project.version}.${BUILD_NUMBER}</finalName>
>>        <modules>
>>            :
>>        </modules>
>>        <archive>
>>             <addMavenDescriptor>false</addMavenDescriptor>
>>             <manifestEntries>
>>
>> <Implementation-Version>${PRJVERSION}</Implementation-Version>
>>             </manifestEntries>
>>         </archive>
>>     </configuration>
>> </plugin>
>>
>> On one of my projects that use these option, I have several, I am finding
>> that I need to delete the plugin in the maven repository so that I get a
>> fresh download of the plugin to get it to package the ear and not
>> complain
>> about not having an application xml file.  Any time I already have the
>> plugin in the repository and build the project it fails with the
>> "application.xml does not exist" error. If I go and then delete the
>> plugin
>> again and built the project it builds fine.
>>
>> This does not happen with other project that I have using the same
>> options?
>>
>> Any idea why this would happen?
>>
>> Thanks.
>>
>> --
>> View this message in context:
>> http://old.nabble.com/Ear-Plugin-Version-5-issue-tp28560014p28560014.html
>> Sent from the Maven - Users mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: users-help@maven.apache.org
>>
>>
> 
> 

-- 
View this message in context: http://old.nabble.com/Ear-Plugin-Version-5-issue-tp28560014p28561249.html
Sent from the Maven - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message