maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: antrun plugin dependency disappearance
Date Tue, 02 Feb 2010 02:06:14 GMT
In Maven 2, only to ensure that the first plugin declaration encountered (usually by putting
it in the root) contains all of the desired plugin dependencies.

I believe that Maven 3 has already fixed the problem.

- Brett

On 02/02/2010, at 12:46 PM, Benson Margulies wrote:

> I think I'm hitting an known issue, but I'm stumped in working around it.
> 
> In an aggregate POM, I've got a use of the maven-antrun-plugin that
> needs custom dependencies.
> 
> They are disappearing.
> 
> The reason, I suspect, is that several of the modules that the
> aggregate POM aggregates are themselves using the antrun plugin, not
> specifying these dependencies. I tried to get past this by hanging the
> dependencies in a pluginManagment section of the profile that turns
> all of this loose, but to no avail. Maven run with -X shows that they
> are gone.
> 
> Is there some more reliable workaround?
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message