maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <and...@hammar.net>
Subject Re: maven download the dependency of a error version?
Date Thu, 28 Jan 2010 09:11:43 GMT
I also see that they add other repositories in their pom. A total mess...

/A

On Thu, Jan 28, 2010 at 10:05, Stephen Connolly <
stephen.alan.connolly@gmail.com> wrote:

> Correct, based on their pom.... this is one of those examples of why it is
> a
> bad plan to add dependencies in a profile that is activated based on the
> build JDK and/or OS
>
> 2010/1/28 maven apache <apachemaven0@gmail.com>
>
> > 2010/1/28 Anders Hammar <anders@hammar.net>
> >
> > > Here you go:
> > >
> > >
> >
> http://repo1.maven.org/maven2/org/apache/rampart/rampart-project/1.4/rampart-project-1.4.pom
> > >
> > > I didn't look closely enough. The JDK1.4 profile is active by default,
> do
> > > as
> > > you're NOT using JDK 1.5 that profile is not going to kick in.
> > >
> > Oh, my fault, I did not check it clearly enouth.
> > You mean not matter which jdk I use( configed in the compile version?),
> as
> > long as the version is not 1.5(for my case , it is 1.6), the jdk14
> profile
> > will be actived?
> >
> > >
> > > /Anders
> > >
> > > On Thu, Jan 28, 2010 at 09:30, maven apache <apachemaven0@gmail.com>
> > > wrote:
> > >
> > > > 2010/1/28 Anders Hammar <anders@hammar.net>
> > > >
> > > > > You're building with JDK 1.4, not JDK 1.5.
> > > >
> > > > How? I did not sepcify 1.4 or .1.5.
> > > > In the parent pom of my project I config the compile version to 1.6,
> > and
> > > my
> > > > eclipse are using jdk1.6_18
> > > >
> > > >
> > > > > There are profiles in the pom of
> > > > >
> > > > > org.apache.rampart:rampart-policy:jar:1.4
> > > > >
> > > > > (Actually, the profiles are in the parent of that project).
> > > > >
> > > > Yes, I know this, I have check the pom.
> > > >
> > > > >
> > > > > The homepage which you refer to isn't telling the complete truth...
> > > > >
> > > > > /Anders
> > > > > On Thu, Jan 28, 2010 at 09:15, maven apache <
> apachemaven0@gmail.com>
> > > > > wrote:
> > > > >
> > > > > > Hi:
> > > > > > I found a strange problem, it seems that maven may download
a
> wrong
> > > > > version
> > > > > > for a transitive dependency.
> > > > > > Details can be found here :
> > > > > > http://dpaste.com/151511/
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message