maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alcaan <alc...@gmail.com>
Subject package org.springframework.osgi.service.importer does not exist
Date Wed, 13 Jan 2010 12:18:48 GMT

Hi!
I'm using Ubuntu 8.04, Maven 2.2.1 and Eclipse with m2eclipse and I'm having
this error:

[ERROR] 
Mojo: 

    org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile

FAILED for project: 

    com.realth:adaptadorUDP:bundle:0.0.1

Reason:

/root/workspace/adaptadorWeb/src/main/java/com/realth/osgi/adapUdp/Listener.java:[8,48]
package org.springframework.osgi.service.importer does not exist

/root/workspace/adaptadorWeb/src/main/java/com/realth/osgi/adapUdp/Listener.java:[10,33]
cannot find symbol
symbol: class OsgiServiceLifecycleListener

I had no problems compiling this project before, and one day started to fail
without doing nothing special. The same project, in my PC with windows XP
and Maven 2.0.10, compiles well. I have tried everything! 
And I know the problem is in the maven-compiler-plugin. Doing some stuff
(installing and reinstalling, maven, java, eclipse...)it started to work
again in Ubuntu but eventually starts failing again... 
Somenone is having this problem? Need some help!!

Albert
-- 
View this message in context: http://old.nabble.com/package-org.springframework.osgi.service.importer-does-not-exist-tp27143992p27143992.html
Sent from the Maven - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message