maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Hennessy <shenne...@astutenetworks.com>
Subject RE: Not a v4.0.0 POM error
Date Thu, 12 Nov 2009 01:19:08 GMT
Pardon me but usually the .pom is an xml text file.
you should be able to open w/ text editor on ubuntu.
try using vi or gedit.

Sean

-----Original Message-----
From: Gerardo Corro [mailto:rob_gar_esp@hotmail.com] 
Sent: Wednesday, November 11, 2009 5:11 PM
To: users@maven.apache.org
Subject: RE: Not a v4.0.0 POM error


It's a valid pom:

$ ls -l maven-install-plugin-2.3.pom
-rw-r--r-- 1 corro corro 1486 2009-11-12 01:33 maven-install-plugin-2.3.pom $ file maven-install-plugin-2.3.pom
maven-install-plugin-2.3.pom: gzip compressed data, from Unix $ gunzip -c  maven-install-plugin-2.3.pom
<?xml version="1.0" encoding="UTF-8"?> <project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>

and the file continues... however Ubuntu "Archive Manager Tool" can't extract it, it says
the pom has errors.

Best regards.


> Date: Thu, 12 Nov 2009 01:21:26 +0100
> Subject: Re: Not a v4.0.0 POM error
> From: nick.stolwijk@gmail.com
> To: users@maven.apache.org
> 
> What do you see if you open it with a browser:
> 
> https://www.mycomp.com/maven2/repository/public/org/apache/maven/plugi
> ns/maven-install-plugin/2.3/maven-install-plugin-2.3.pom
> 
> Is it a valid pom or some garble?
> 
> With regards,
> 
> Nick Stolwijk
> ~Java Developer~
> 
> IPROFS BV.
> Claus Sluterweg 125
> 2012 WS Haarlem
> http://www.iprofs.nl
> 
> 
> 
> On Thu, Nov 12, 2009 at 12:19 AM, Gerardo Corro <rob_gar_esp@hotmail.com> wrote:
> >
> > Hi,
> >
> > Thanks for your message, however is not working :-(  the same error is triggered
again.
> >
> > Best regards
> >
> >
> >
> >
> >>
> >> I suggest you to delete the directory in your local repository
> >>
> >> /data/repository/org/apache/maven/plugins/maven-install-plugin/2.3/
> >>
> >> anyway, for me nothing to see with ubuntu (I works on it too)
> >>
> >> I already had such errors when a download of an artifact failed 
> >> (for multiple reason...)
> >>
> >> hope it will help you.
> >>
> >> Cheers,
> >>
> >> Tony.
> >>
> >> >
> >> > [WARNING] *** CHECKSUM FAILED - Checksum failed on download: 
> >> > local = 'e6084a3bb5d435dcb42378cd3273f5db433cb944'; remote = '    
> >> > ' - RETRYING
> >> > Downloading:
> >> > https://www.mycomp.com/maven2/repository/public/org/apache/maven/
> >> > plugins/maven-install-plugin/2.3/maven-install-plugin-2.3.pom
> >> > 1K downloaded  (maven-install-plugin-2.3.pom) [WARNING] *** 
> >> > CHECKSUM FAILED - Checksum failed on download: local = 
> >> > 'e6084a3bb5d435dcb42378cd3273f5db433cb944'; remote = '    ' - 
> >> > IGNORING [INFO]
> >> > -----------------------------------------------------------------
> >> > -------
> >> > [ERROR] BUILD ERROR [INFO]
> >> > -----------------------------------------------------------------
> >> > ------- [INFO] Error building POM (may not be this project's 
> >> > POM).
> >> >
> >> >
> >> > Project ID: org.apache.maven.plugins:maven-install-plugin
> >> > POM
> >> > Location: 
> >> > /data/repository/org/apache/maven/plugins/maven-install-plugin/2.
> >> > 3/maven-install-plugin-2.3.pom
> >> >
> >> > Reason: Not a v4.0.0 POM. for project 
> >> > org.apache.maven.plugins:maven-install-plugin
> >> > at 
> >> > /data/repository/org/apache/maven/plugins/maven-install-plugin/2.
> >> > 3/maven-install-plugin-2.3.pom
> >> >
> >> >
> >> >
> >> > if using the -e version I get:
> >> >
> >> > [INFO]
> >> > -----------------------------------------------------------------
> >> > ------- [INFO] Trace 
> >> > org.apache.maven.lifecycle.LifecycleExecutionException: Unable to 
> >> > build project for plugin 'org.apache.maven.plugins:maven-install-plugin':
> >> > Not a v4.0.0 POM. for project 
> >> > org.apache.maven.plugins:maven-install-plugin
> >> > at 
> >> > /data/repository/org/apache/maven/plugins/maven-install-plugin/2.
> >> > 3/maven-install-plugin-2.3.pom
> >> > at
> >> > org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(
> >> > DefaultLifecycleExecutor.java:1557)
> >> > at
> >> > org.apache.maven.lifecycle.DefaultLifecycleExecutor.getMojoDescri
> >> > ptor(DefaultLifecycleExecutor.java:1851)
> >> > at
> >> > org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindLifecycle
> >> > ForPackaging(DefaultLifecycleExecutor.java:1311)
> >> > at
> >> > org.apache.maven.lifecycle.DefaultLifecycleExecutor.constructLife
> >> > cycleMappings(DefaultLifecycleExecutor.java:1275)
> >> >
> >> >
> >> >
> >> > Caused by: org.apache.maven.plugin.InvalidPluginException: Unable 
> >> > to build project for plugin 
> >> > 'org.apache.maven.plugins:maven-install-plugin': Not a v4.0.0 
> >> > POM. for project org.apache.maven.plugins:maven-install-plugin
> >> > at 
> >> > /data/colibria/repository/org/apache/maven/plugins/maven-install-
> >> > plugin/2.3/maven-install-plugin-2.3.pom
> >> > at
> >> > org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVe
> >> > rsion(DefaultPluginManager.java:293)
> >> > at
> >> > org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugi
> >> > n(DefaultPluginManager.java:205)
> >> >
> >> >
> >> >
> >> > Please assist. Thanks!
> >> >
> >> >
> >> >
> >> >
> >> >
> >> >
> >> > _________________________________________________________________
> >> > Windows Live: Keep your friends up to date with what you do online.
> >> > http://www.microsoft.com/middleeast/windows/windowslive/see-it-in
> >> > -action/social-network-basics.aspx?ocid=PID23461::T:WLMTAGL:ON:WL
> >> > :en-xm:SI_SB_1:092010
> >>
> >>
> >> --
> >>
> >> Tony Chemit
> >> --------------------
> >> tél: +33 (0) 2 40 50 29 28
> >> email: chemit@codelutin.com
> >> http://www.codelutin.com
> >>
> >> -------------------------------------------------------------------
> >> -- To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> >> For additional commands, e-mail: users-help@maven.apache.org
> >>
> >
> > _________________________________________________________________
> > Windows Live Hotmail: Your friends can get your Facebook updates, right from Hotmail®.
> > http://www.microsoft.com/middleeast/windows/windowslive/see-it-in-ac
> > tion/social-network-basics.aspx?ocid=PID23461::T:WLMTAGL:ON:WL:en-xm
> > :SI_SB_4:092009
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
 		 	   		  
_________________________________________________________________
Keep your friends updated-even when you're not signed in.
http://www.microsoft.com/middleeast/windows/windowslive/see-it-in-action/social-network-basics.aspx?ocid=PID23461::T:WLMTAGL:ON:WL:en-xm:SI_SB_5:092010
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message