maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lahiru Gunathilake <glah...@gmail.com>
Subject Re: How to fix the java.net repository relocation
Date Thu, 12 Nov 2009 06:58:16 GMT
Hi Stephen,

On Thu, Nov 12, 2009 at 12:10 PM, Stephen Connolly <
stephen.alan.connolly@gmail.com> wrote:

> AFAIK,
>
> Axis2 is an apache project and would be deploying to repo1.maven.org.
> The rules for repo1.maven.org are that you cannot rely on any
> artifacts which are not hosted on repo1.maven.org.
>
I think there were artifacts hosted and now it's moved.

As such, I would expect that Axis2 _should not_ require artifacts from
> java.net, and should not have any <repository> sections in their
> pom.xml files.

Yes axis2 doesn't have any repository section in it's pom files but when I
manually add the relocated repo in to the Axis2 pom it successfully get some
of the artifacts and later on it again refer to the wrong location and get a
html content in the the pom file. please refer the error here[1].

> (OK technically they are allowed ones which are only
> enabled for -SNAPSHOTs... but it cannot be enabled for releases)
>
> That is the theory, now it may well be that Axis2 is being bold and
> depending on java.net.
>
> To answer your question.  Your best bet is to set up a maven
> repository manager (e.g. nexus, artifactory, etc) and configure your
> settings.xml to use that repository manager as <mirrofOf>*</mirrorOf>
>
I will try for this and get back to you.


[1]http://www.pastie.org/694974
Thanks in advance
Lahiru

>
> Then you can add all the repositories you want to source artifacts
> from to your repository manager, and you should be able to build.
>
> Also this sounds more like a question for the Axis2 list
>
> -Stephen
>
> 2009/11/12 Lahiru Gunathilake <glahiru@gmail.com>:
> > Hi all,
> >
> > I am trying to build set stack of java products which fails due to the
> > relocation of https://maven-repository.dev.java.net/nonav/repository/.
> From
> > the product stack I am buiding Apache Axis2 very first and I cannot see
> this
> > repository in Axis2 pom.xml. So I tried to put the new location in to
> Axis2
> > pom and tried to build but still it's failing with some other artifacts.
> I
> > wanted to change the location where we artifacts pointing to this
> location,
> > so I ran a grep command inside my .m2 directory but I couldn't find any
> of
> > the .pom file where it refer to this repository.
> >
> > I'm ahead of a release and have to do a clean repository build, so can
> > someone please help me to avoid this problem.
> >
> > Regards
> > Lahiru
> >
> > --
> > Apache Qpid, Worlds dominant messaging middleware..!!!
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>


-- 
Apache Qpid, Worlds dominant messaging middleware..!!!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message