maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hüseyin Kartal <h.kar...@hsyn.de>
Subject maven-eclipse-plugin issue
Date Fri, 09 Oct 2009 16:21:19 GMT
Hi

i have a problem with the maven-eclipse-plugin.
my projects pom.xml look like this

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="
http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>de.hsyn.crtl</groupId>
<artifactId>crtl</artifactId>
<packaging>jar</packaging>
<version>1.0-SNAPSHOT</version>
<name>crtl</name>
<url>http://hsyn.de</url>
<dependencies>

... other dependencies
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>com.springsource.org.aspectj.runtime</artifactId>
<version>1.6.6.RELEASE</version>
</dependency>
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>com.springsource.org.aspectj.tools</artifactId>
<version>1.6.6.RELEASE</version>
</dependency>
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>com.springsource.org.aspectj.weaver</artifactId>
<version>1.6.6.RELEASE</version>
</dependency>

...
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.6</source>
<target>1.6</target>
<encoding>UTF-8</encoding>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-resources-plugin</artifactId>
<configuration>
<downloadSources>true</downloadSources>
<downloadJavadocs>true</downloadJavadocs>
<encoding>UTF-8</encoding>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-eclipse-plugin</artifactId>
<configuration>
<encoding>UTF-8</encoding>
</configuration>
</plugin>
</plugins>
</build>
<repositories>
<repository>
<id>com.springsource.repository.bundles.release</id>
<name>SpringSource Enterprise Bundle Repository - SpringSource Bundle
Releases</name>
<url>http://repository.springsource.com/maven/bundles/release</url>
</repository>
<repository>
<id>com.springsource.repository.bundles.external</id>
<name>SpringSource Enterprise Bundle Repository - External Bundle
Releases</name>
<url>http://repository.springsource.com/maven/bundles/external</url>
</repository>
</repositories>
</project>



on the command line maven resolves all dependencies and compile successfull,
but if i generate eclipse project files with the maven-eclipse-plugin. the
three dependencies to the "org.aspectj" won´t referenced in the eclipse
project. all other dependencies are correct.

it drives me crazy. tried everything like clean eclipse:clean refresh the
project etc.

please help.

i thougth that eventualy there is a hidden feature in maven for aspects.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message