maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: I would like build to fail
Date Tue, 20 Oct 2009 09:43:58 GMT
dependencyManagement applies the settings to all dependencies - so  
you've effectively declared all dependencies to be [1.0.0].

- Brett

On 20/10/2009, at 8:39 PM, Borut BolĨina wrote:

> Hi,
>
> if in parent pom (company POM for example):
>
> <dependencyManagement>
>    <dependencies>
>        <dependency>
>            <groupId>com.acme</groupId>
>            <artifactId>coyote-tornado-kit</artifactId>
>            <version>[1.0.0]</version>
>        </dependency>
> </dependencyManagement>
>
> and in some project:
>
> <dependencies>
>    <dependency>
>        <groupId>com.acme</groupId>
>        <artifactId>coyote-tornado-kit</artifactId>
>        <version>[2.0.0]</version>
>    </dependency>
> </dependencies>
>
> then I would expect build to fail becouse hard versions are used.  
> Why is
> that not so?
>
> -Borut


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message